Gazebo | Ignition | Community
Ask Your Question
0

How do I run ignition gazebo distributed (server on one machine, GUI on another)?

asked 2021-02-10 17:57:01 -0500

Rick Armstrong gravatar image

Hello,

I'm trying to figure out how to run ignition gazebo -s shapes.sdf on one machine, and ignition gazebo -gon another (both hosts on the same LAN). I've found the tutorial at https://ignitionrobotics.org/api/gaze..., but it's pretty terse. I tried this: ign gazebo -s --network-role=primary --network-secondaries=1 --distributed shapes.sdf, but it fails with

Traceback (most recent call last):
    2: from /usr/bin/ign:267:in `<main>'
    1: from /usr/lib/ruby/ignition/cmdgazebo3.rb:324:in `execute'
/usr/lib/ruby/ignition/cmdgazebo3.rb:310:in `parse': invalid option: --distributed (OptionParser::InvalidOption)

I'm running Citadel on Ubuntu 18.

I get the impression that the docs are a little rough. Any suggestions on where to look for more documentation or examples?

edit retag flag offensive close merge delete

Comments

Bump. Has nobody tried this?

Rick Armstrong gravatar imageRick Armstrong ( 2021-10-25 23:33:44 -0500 )edit

Oh dear, is this still ongoing? Any luck?

kakcalu13 gravatar imagekakcalu13 ( 2022-02-18 10:48:17 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2023-03-19 12:47:09 -0500

civcode gravatar image

Had the same problem and landed here googling for a solution. Eventually I found out that you have to set an environment variable to tell the GUI which host and user to connect to.

See Gazebo environment variables.

My Setup:

  • Gazebo Fortress
  • The simulation is running on machine 1, the GUI is running on machine 2.
  • Both machines are in the same subnet (192.168.0.xyz).

Machine 1 (simulation):

  • user: user1
  • hostname: host1

Machine 2 (GUI):

  • user: user2
  • hostname: host2

Start the simulation on machine 1:

  • $ ign gazebo -v 4 shapes.sdf -s

Set environment variable and start GUI on machine 2:

  • $ export IGN_PARTITION=host1:user1
  • $ ign gazebo -v 4 -g

The default setting for UDS multicast works for me (see IGN_DISCOVERY_MULTICAST_IP).

Hope that helps!

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2021-02-10 17:57:01 -0500

Seen: 521 times

Last updated: Mar 19 '23