Gazebo | Ignition | Community
Ask Your Question

I cannot install file. How can i?

asked 2021-04-04 07:13:26 -0500

HarunBerk gravatar image


I tried to create a world with satellite images using libStaticMapPlugin.

But i get an error like this:

[Err] [Plugin.hh:180] Failed to load plugin cannot open shared object file: No such file or directory

than i find the package which keeps plugins and cannot see static map plugin.

I use Gazebo 9 on Ubuntu 18.04

How can i install libStaticMapPlugin?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2021-04-19 18:50:25 -0500

HarunBerk gravatar image

Firstly, thanks for your answers.

I have already searched for the plugin in that folders but it was not exist.

@BillThePlatypus said "the plugin is for gazebo10" than i think the plugin doesn't exist on gazebo9

but i saw the repo including the plugin with @Veerachart 's answer.

so, i expected, my system doesn't allowed to install packages from

i watched those steps to get plugin:

1.Setup my computer to accept software from

sudo sh -c 'echo "deb lsb_release -cs main" > /etc/apt/sources.list.d/gazebo-stable.list'

  1. update packages

sudo apt-get update

  1. tried to open gazebo but i have faced with a problem:

gazebo: symbol lookup error: /usr/lib/x86_64-linux-gnu/ undefined symbol: _ZN8ignition10fuel_tools12ClientConfig12SetUserAgentERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE

  1. upgraded the libraries with

sudo apt upgrade libignition-math2

  1. than tried to run gazebo and it worked well

gazebo --verbose

Thanks everyone, these are my experiences. I hope it can help others.

edit flag offensive delete link more

answered 2021-04-06 03:31:48 -0500

Veerachart gravatar image

I'm on gazebo11 and I found in /usr/lib/x86_64-linux-gnu/gazebo-11/plugins. The plugin also exists in the main repo for gazebo-9 (, so I think it should be similar in gazebo-9.

Did you source the setup file (/usr/share/gazebo-9/ before running? If the output of echo $GAZEBO_PLUGIN_PATH doesn't contain the path to the so file, the plugin cannot be found.

edit flag offensive delete link more

answered 2021-04-08 11:33:29 -0500

bach gravatar image

If you have the file somewhere, you can copy and paste it to ~/your_workspace_ws/devel/lib folder. Now Gazebo should be able to find it.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2021-04-04 07:13:26 -0500

Seen: 598 times

Last updated: Apr 19 '21