Robot moving at slower velocity in Gazebo (gazebo output velocity is half of cmd_vel)

asked 2021-04-05 16:01:11 -0600

mifta92 gravatar image

updated 2021-04-06 15:12:14 -0600

Dear all C:\fakepath\Screenshot from 2021-04-05 18-18-54.png I am simulating a mobile manipulator (warthog UGV and UR10e) in Gazebo 9.16.0 and ROS melodic. For the robot base, I am using diff_drive_controller and for the arm I am using Effort_controller. I have modified a little bit in the URDF of warthog UGV. I have added dynamics damping and friction value in urdf to restrict the free fall of arm and chassis. Using the cmd_vel topic, I am providing 2m/s linear velocity in x direction. But, robot is moving slowly, at half of the input speed in Gazebo. I have tried changing and deleting the mu1, mu2, kp, kd and fdir1 values and also manually setting the PID values <<front_left_wheel_joint: {p:="" 100.0,="" i:="" 0.01,="" d:="" 0.001}&gt;&gt;="" please="" help="" me,="" i="" cant="" find="" the="" problem.="" <="" p="">

edit 1: I have tried the simulation without loading the arm controller and robot velocity is working as expected. I have no idea what is wrong with the effort controller, no warning or error. Previously, I tried Position controller but it didn't work.

edit retag flag offensive close merge delete

Comments

See if increasing the wheelTorque parameter in the diff drive controller configuration fixes your problem.

nlamprian gravatar imagenlamprian ( 2021-04-06 05:00:58 -0600 )edit

thanks, I tired. But problem still exists. tried with very high wheel torque value (1000). If I run the simulation without arm controller then it is working fine. But I need the arm controller for manipulation.

mifta92 gravatar imagemifta92 ( 2021-04-06 15:09:26 -0600 )edit

Try changing the controller type and see if it makes any difference. Then I would also look into the inertias of the links.

nlamprian gravatar imagenlamprian ( 2021-04-12 05:27:15 -0600 )edit

Initially I was using velocity controller for both arm and robot base. Now, I am using velocity controller for robot base and position controller for robotic arm. I have also tried changing the inertias. I am still facing the problem. It is very difficult to tune the inertial values manually.

mifta92 gravatar imagemifta92 ( 2021-04-19 12:08:28 -0600 )edit