Home | Tutorials | Wiki | Issues
Ask Your Question
1

Failures when launching qualification worlds

asked 2013-05-07 20:06:52 -0500

gerkey gravatar image

Extracted from question 2665

When using roslaunch atlas_utils qual_task_x.launch to launch the simulator, you have to launch it 4-5 times before the simulator actually launches and runs alright. There are a number of issues that happen here.

  1. The simulator starts and gets stuck displaying no timing or anything on the window. Just a grey window.
  2. The simulator starts and then writes to the log file and never displays a window.
  3. The simulator starts and does not write to the log file, does not show a window, and yet thinks that it has fully started and is running.
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-05-07 20:11:34 -0500

gerkey gravatar image

Your situation 1 (grey window) sounds like this known bug. A workaround for that situation is start another instance of gzclient in parallel. Don't close the non-functional gzclient window (you can minimize it).

Your situations 2 and 3 are new to me. My first guess is that there's a problem with your GPU driver configuration. What kind of graphics card are you using? Can you provide console output from the terminal where you ran roslaunch and encountered these situations?

edit flag offensive delete link more

Comments

I was running an Intel Card. Now I have switched to an NVIDIA card just now and have not had the problem yet. Need more time to test it out. The window seems to display each time now that I switched graphics cards.

aqiruse gravatar imageaqiruse ( 2013-05-10 15:35:27 -0500 )edit

I am sorry for the mistake. The computer I am using advertises an NVIDIA card in it. I thought they meant the primary graphics card was an NVIDIA. What they meant, and did not advertise, is that while yes it does have an NVIDIA card in it, the primary two adapters are NOT NVIDIA. They are Intel. Sorry for the mistake on my part.

aqiruse gravatar imageaqiruse ( 2013-05-10 15:47:25 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-05-07 20:06:52 -0500

Seen: 108 times

Last updated: May 07 '13