DRC robot doesn't respond to commands [closed]

asked 2013-05-07 20:18:26 -0500

gerkey gravatar image

updated 2013-05-07 20:22:46 -0500

Extracted from question 2665

When the simulator does start, and the atlas robot is successfully standing still waiting for commands, sometimes after using rosrun package_name module_name the atlas robot will stay standing still and not perform any commands at all as though it did not receive the command input. Instead the plugin must be stopped, and re-run and then (without recompiling or making any changes to the code) atlas robot will actually respond to the commands.

Sometimes when controlling the atlas robot using rosrun, atlas will execute a few commands and then stop and refuse to continue executing commands. The same controller plugin is able to be ran again without recompiling or altering the code in any way, and the controller will successfully get atlas to perform all the commands. It is just atlas sometimes randomly decides to stop performing commands.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by nkoenig
close date 2013-09-19 11:10:43.074650

Comments

Which version of drcsim are you running? When you say `rosrun package_name module_name`, what commands are you running? What result are you expecting?

gerkey gravatar imagegerkey ( 2013-05-07 20:19:25 -0500 )edit

I am using drcsim 2.5. The commands I am running are `rosrun qual_task_1_bdi qual_task_1_bdi`. that is the package name I have written as well as the module (application) name I have written within the package. I am expecting the atlas robot to execute the entire chain of commands. Instead atlas will just sometimes execute a few of the commands and then totally stop running. Tried on both Intel and NVIDIA cards with same result.

aqiruse gravatar imageaqiruse ( 2013-05-10 15:30:49 -0500 )edit
1

Can you post the code for the qual_task_1_bdi program? It's hard to know what's going on otherwise.

gerkey gravatar imagegerkey ( 2013-05-22 17:00:27 -0500 )edit