Gazebo | Ignition | Community
Ask Your Question
0

Shadow is not visible in Rviz whiled rendering images from an RGB-D camera.

asked 2021-08-21 05:53:56 -0500

Ani_sim gravatar image

Hi,

I am using D435 RGBD camera model for a Gazebo simulation. However, while turning on /camera/color/image_raw topic in the Rviz, the acquired image does not show any shadow. Please let me know how to enable shadow in the rendered image? An image of the same has been attached here.C:\fakepath\snap_01.png

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-08-30 05:02:56 -0500

Veerachart gravatar image

I have answered it once here, not sure if the problem has been solved on the Gazebo side or not. Depth camera disables lighting, and therefore shadows don't show up.

Set <always_on>false</always_on> to the depth camera. Then after you start the simulation, enable the camera (by the Topic Visualization, or a sensor plugin).

edit flag offensive delete link more

Comments

I tried setting <always_on>false</always_on> in the .urdf file of the camera. But, it then does not capture anything.

Ani_sim gravatar imageAni_sim ( 2021-08-30 05:35:41 -0500 )edit

Can you try opening the Topic Visualizer from Gazebo GUI once? I don't know if the ROS plugin activates the camera or not.

Veerachart gravatar imageVeerachart ( 2021-08-31 04:26:02 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-08-21 05:53:56 -0500

Seen: 18 times

Last updated: Aug 30