Header not found gazebo/math/Rand.hh

asked 2021-08-27 11:22:33 -0500

While following the following question to detect mouse click events, https://answers.gazebosim.org//questi..., I saw my computer cannot find the header file gazebo/math/Rand.hh

Here is my CMakeLists.txt:

cmake_minimum_required(VERSION 2.8 FATAL_ERROR)

find_package(gazebo REQUIRED)
include_directories(${GAZEBO_INCLUDE_DIRS})
link_directories(${GAZEBO_LIBRARY_DIRS})
list(APPEND CMAKE_CXX_FLAGS "${GAZEBO_CXX_FLAGS}")

add_library(hello_world SHARED hello_world.cc)
target_link_libraries(hello_world ${GAZEBO_LIBRARIES})

I am on Ubuntu 18.04, my ROS version is melodic and I have gazebo-9

I tried to find if I have gazebo/math in my include directory. I am not sure if this is the correct approach, but I ran the following commands

locate gazebo | grep include | grep math

This did not show any gazebo/math directory in the includes folder.

But running this command shows that I have gazebo/gui folder in my include directory

locate gazebo | grep include | grep gui

edit retag flag offensive close merge delete

Comments

Which version of ignition-math do you have in your system? (dpkg -l | grep ignition-math). What does dpkg -L libignition-math6-dev | grep Rand returns?

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2021-09-03 10:12:12 -0500 )edit