Gazebo | Ignition | Community
Ask Your Question
0

gzserver: error while loading shared libraries: libdart-collision-bullet.so.6: cannot open shared object file: No such file or directory

asked 2021-08-27 22:02:25 -0500

kakcalu13 gravatar image

I don't even know how did this happen. One day, I just open the laptop and start to work. Suddenly, it's not working anymore.

I can't even run turtlebot3. I reinstalled foxy and gazebo11. No luck. It just...out of blue not working again.

killall gzserver/killall gzclient/ pkill doesn't help at all. ANy idea? I really want to use gazebo again

error

gzserver: error while loading shared libraries: libdart-collision-bullet.so.6: cannot open shared object file: No such file or directory

even i reinstall gazebo11, this happens still.

bwuk@robots:~$ cd /usr/local/bin/gazebo
bash: cd: /usr/local/bin/gazebo: No such file or directory
bwuk@robots:~$

I still have .model though

bwuk@robots:~$ cd .gazebo/models/
bwuk@robots:~/.gazebo/models$

Everytime I load gazebo from launch, it simply frozen, crashed or says directory doesn't exist.

How did this happen?

I even echo path, but it just don't show any result

bwuk@robots:~$ echo $GAZEBO_RESOURCE_PATH

bwuk@robots:~$ echo $GAZEBO_PLUGIN_PATH

bwuk@robots:~$
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2021-08-31 10:58:46 -0500

kakcalu13 gravatar image

updated 2021-09-17 13:46:34 -0500

Solution:

sudo apt remove --purge libdart*
Remove dartsim/ppa in Software & Updates -> Other Software
sudo apt update
sudo apt install libdart-dev
sudo apt install libdart-all-dev (only if above installs)

But if this failed due to unable to fetch some archives, run this

    sudo apt update --fix-missing && sudo apt install libdart-all-dev


    Install gazebo curl -sSL http://get.gazebosim.org | sh

Finally,

Type gazebo (to check if it works now)

If you still getting error after attempt to load gazebo from launch in ros2, then follow this;

. /usr/share/gazebo/setup.sh inside your workspace.

Source:

ROS answer: [link](https://answers.ros.org/question/385317/gzserver-error-while-loading-shared-libraries-libdart-collision-bulletso6-cannot-open-shared-object-file-no-such-file-or-directory/)

rajputusername on stackoverflow on Gazebo 11 does not run question page
edit flag offensive delete link more
0

answered 2021-09-15 16:03:35 -0500

updated 2021-09-15 17:09:18 -0500

last days my gazebo ran successfully but now isn't work. i have the same issue and i did the solution that @kakcalu13 described :

i tried 1st solution :

i copied this lines step by step

sudo apt remove --purge libdart* > OK

sudo apt update >OK

sudo apt install libdart-dev >Failed

the error says :

The following packages have unmet dependencies: libdart-dev : Depends: libdart6 (= 6.9.2-2build4) but 6.9.5-1885~202012292349~ubuntu20.04.1 is to be installed E: Unable to correct problems, you have held broken packages.

so i tried the second solution by running this line on Terminal :

sudo apt update --fix-missing && sudo apt install libdart-all-dev

but the following lines is the error i got in Terminal :

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: libdart-all-dev : Depends: libdart-dev but it is not going to be installed Depends: libdart-planning-dev but it is not going to be installed Depends: libdart-utils-dev but it is not going to be installed Depends: libdart-utils-urdf-dev but it is not going to be installed Depends: libdart-gui-dev but it is not going to be installed Depends: libdart-gui-osg-dev but it is not going to be installed Depends: libdart-optimizer-nlopt-dev but it is not going to be installed Depends: libdart-optimizer-ipopt-dev but it is not going to be installed Depends: libdart-collision-bullet-dev but it is not going to be installed Depends: libdart-collision-ode-dev but it is not going to be installed E: Unable to correct problems, you have held broken packages.

actually the error says :

E: Unable to correct problems, you have held broken packages.

any solution? (i,m extremely amateur on ubuntu)

edit flag offensive delete link more

Comments

Sorry for the late reply! Seems like gazebo doesn't notify me until I get on this site.

I tried to upload an image, but there's maximum limit so here is the link: https://askubuntu.com/questions/14024...

I still have the image of this link if anyone ever needs.

Please let me know if it solved your issue! If it did, I will upload with lower mb in the answer!

kakcalu13 gravatar imagekakcalu13 ( 2021-09-17 13:49:17 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-08-27 22:02:25 -0500

Seen: 208 times

Last updated: Sep 17