Gazebo | Ignition | Community
Ask Your Question

error while starting gazebo : gzserver: error while loading shared libraries:

asked 2021-09-16 15:34:54 -0500

Hamid Smith Salehi gravatar image

updated 2021-09-17 11:42:55 -0500

i' on Ubunto 20.04 and installed Gazebo11

while using command "gazebo" to start using it, i got this error : gzserver: error while loading shared libraries: cannot open shared object file: No such file or directory

i also followed some instructions from here :

that are :

sudo apt remove --purge libdart*
Remove dartsim/ppa in Software & Updates -> Other Software
sudo apt update
sudo apt install libdart-dev
sudo apt install libdart-all-dev (only if above installs)

i ran on Terminal :

sudo apt remove --purge libdart*
sudo apt update

it was OK but after this line had error :

sudo apt install libdart-dev

and the error said :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libdart-dev : Depends: libdart6 (= 6.9.2-2build4) but 6.9.5-1885~202012292349~ubuntu20.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

and the person who wrote the answer ( it's verified answer from someone who asked help for exact issue that i have ), recommended another way to fix the issue as a backup way when 1st wasn't successful; that is :

"" But if this failed due to unable to fetch some archives, run this : ""

    sudo apt update --fix-missing && sudo apt install libdart-all-dev

but it didn't work for me and i got this error after trying it :

E: Unable to correct problems, you have held broken packages.

so i searched through the internet to fix this error and i have seen some solutions but didn't work :

for example this one wasn't clear for me to do it :

and others didn't work

i also ran this command, i found it from here :

i did it may helps to find the reason of the issue :

ldd $(which gzserver) | grep dart

and the output was : => not found => not found => not found

and also ran this :

find /usr . -name*

and the output was : => not found => not found => not found
root@hamids23:~# find /usr . -name*

i also checked this :

and it wasn't helpful for me (i'm completely amateur on Linux and only able to fix my issues by step-by-step solutions, so maybe, because it wasn't clear for me)

any solution ?

edit retag flag offensive close merge delete


I'm facing exactly the same issue. How did you solve it please?

BobLaMortadelle gravatar imageBobLaMortadelle ( 2023-01-10 04:09:57 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2023-01-10 09:14:23 -0500

BobLaMortadelle gravatar image

Hi, I faced the same problem and I've finaly managed to get gazebo running again. At first, I decided to redownload gazebo after a predownload of ROS2 (foxy for ubuntu, latest available package). Then I predownloaded Gazebo for Ubuntu. Basically I followed this tutorial to download gazebo :

then I ran the following command:

sudo apt install ros-foxy-gazebo-ros-pkgs

just like described in the tutorial. I don't think this part was truly necessary in both our situation, but at least I made it to get ROS2.

Anyway, I was still in trouble with dependencies, and my command couldn't run. Therefore, I decided to use the command

sudo aptitude install ros-foxy-gazebo-ros-pkgs

the first choice I had was:

      Keep the following packages at their current version:
1)      libdart-collision-bullet-dev [Not Installed]
2)      libdart-collision-ode-dev [Not Installed]
3)      libdart-dev [Not Installed]
4)      libdart-external-ikfast-dev [Not Installed]
5)      libdart-external-odelcpsolver-dev [Not Installed]
6)      libdart-utils-dev [Not Installed]
7)      libdart-utils-urdf-dev [Not Installed]
8)      libgazebo11-dev [Not Installed]
9)      ros-foxy-gazebo-dev [Not Installed]
10)     ros-foxy-gazebo-plugins [Not Installed]
11)     ros-foxy-gazebo-ros [Not Installed]
12)     ros-foxy-gazebo-ros-pkgs [Not Installed]

it didn't work for me so I decided to relaunch the same command line and decline this first choice. the next choice was:

      Remove the following packages:
1)      libdart6-collision-bullet-dev [6.12.2-2043~202208070503~ubuntu20.04.1 (focal, now)]
2)      libdart6-dev [6.12.2-2043~202208070503~ubuntu20.04.1 (focal, now)]
3)      libdart6-external-odelcpsolver-dev [6.12.2-2043~202208070503~ubuntu20.04.1 (focal, now)]
4)      libdart6-utils-dev [6.12.2-2043~202208070503~ubuntu20.04.1 (focal, now)]
5)      libdart6-utils-urdf-dev [6.12.2-2043~202208070503~ubuntu20.04.1 (focal, now)]

      Install the following packages:
6)      libdart6-collision-ode [6.9.2-2build4 (focal)]

      Downgrade the following packages:
7)      libdart6 [6.12.2-2043~202208070503~ubuntu20.04.1 (focal, now) -> 6.9.2-2build4 (focal)]
8)      libdart6-collision-bullet [6.12.2-2043~202208070503~ubuntu20.04.1 (focal, now) -> 6.9.2-2build4 (focal)]
9)      libdart6-external-odelcpsolver [6.12.2-2043~202208070503~ubuntu20.04.1 (focal, now) -> 6.9.2-2build4 (focal)]
10)     libdart6-utils [6.12.2-2043~202208070503~ubuntu20.04.1 (focal, now) -> 6.9.2-2build4 (focal)]
11)     libdart6-utils-urdf [6.12.2-2043~202208070503~ubuntu20.04.1 (focal, now) -> 6.9.2-2build4 (focal)]

I accepted and it worked, I just had to launch gazebo after that, using


The key must be to keep going with aptitude and downgrade libdart.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2021-09-16 15:34:54 -0500

Seen: 652 times

Last updated: Sep 17 '21