Gazebo | Ignition | Community
Ask Your Question
0

Why are Gazebo textures and colors mixed up with background windows or black?

asked 2021-09-27 04:28:57 -0500

JasBot gravatar image

updated 2021-10-12 01:37:25 -0500

Hi,

I'm running Gazebo 11.5.1 and ROS Galactic on Ubuntu 20. When I load the house model in gazebo, I get the following.

image description

The textures and colors are not right and mixed with the visual of the other software windows that I'm running. Any ideas on what could be causing the issue?

More details:

  • When I start an empty gazebo world and add objects to it, they are loaded just fine.
  • If I save the model and load it, the objects have weird appearance again.
  • If I add a new instance of an object, it appears the exact same as the one in the model with weird texture and color.

    Tested it it with a fresh Gazebo build from source too but the problem is still there. This is really blocking because I'm testing a visual slam algorithm so the scene appearance is critical.

Any help would be appreciated!

Thanks,

Jas

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-10-18 20:59:29 -0500

JasBot gravatar image

So, This problem was here for a while but it was fixed "on it's own".

I had some problems with my graphics card driver so I reinstalled everything and checked the BIOS settings as well. Once everything reinstalled, the texture and color rendering was working fine again.

It was a confusing problem to have and no errors or warnings were detected even in verbose mode.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-09-27 04:21:29 -0500

Seen: 21 times

Last updated: yesterday