Gazebo | Ignition | Community
Ask Your Question

Libogre Error

asked 2012-11-24 22:13:51 -0500

mfahad gravatar image

Hi all,

I am facing a problem with Gazebo. When I install it on my machine running Ubuntu Linux 12.04, it works fine but when I restart the computer and try to run it, it gives me the following error.

gazebo: error while loading shared libraries: cannot open shared object file: No such file or directory

Has any body else faced the same problem? What might be the possible solution?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2012-11-27 12:17:53 -0500

nkoenig gravatar image

Make sure you sourced the file that is installed in /usr/share/gazebo-<version>.

I place the following line in my ~/.bashrc file so that is sourced at the appropriate time:

source /usr/share/gazebo-1.2/

edit flag offensive delete link more


Thanks, that fixed it.

mfahad gravatar imagemfahad ( 2012-11-28 09:11:07 -0500 )edit

@mfahad, please mark Nate's answer as being correct if possible so that others can easily see the problem is solved.

asomerville gravatar imageasomerville ( 2012-11-29 13:49:52 -0500 )edit
Login/Signup to Answer

Question Tools


Asked: 2012-11-24 22:13:51 -0500

Seen: 604 times

Last updated: Nov 27 '12