Actor Plugin in Gazebo-11 not starting on ground pane?

asked 2021-10-28 12:28:03 -0600

Julian94 gravatar image

I am trying to follow the tutorial on how to make an animated model from Gazebo: http://gazebosim.org/tutorials?tut=ac... to simulate people walking around my bot but the actors seem to be up some units on the z-axis and are floating. image description

I have adjusted the SDF to my world and I adjusted the pose as shown below but it still is not working.

 <actor name="actor1">
  <pose>0 1 0 0 0 0</pose>
  <skin>
    <filename>walk.dae</filename>
    <scale>1.0</scale>
  </skin>
  <animation name="walking">
    <filename>walk.dae</filename>
    <scale>1.000000</scale>
    <interpolate_x>true</interpolate_x>
  </animation>

  <plugin name="actor1_plugin" filename="libActorPlugin.so">
    <target>0 -5 1.2138</target>
    <target_weight>1.15</target_weight>
    <obstacle_weight>1.8</obstacle_weight>
    <animation_factor>5.1</animation_factor>

I am wondering if the plugin has its parameters to stay within bounds of the z-axis at some units above 1 but I'm not sure. I am using Gazebo-11 Ros2 Foxy. How can I fix this so that my actors are on the ground plane. I have changed the pose many times but nothing works.

edit retag flag offensive close merge delete