Gazebo | Ignition | Community
Ask Your Question
0

Ignition Edifice Gazebo black screen

asked 2022-01-06 02:51:47 -0500

TImSw gravatar image

Hi There,

I followed the instructions to install ignition with the binary installation. After that I tried to start a simple gazebo world. However I only get a black window.

When I try ign gazebo or ign gazebo shapes.sdf, I only get a black screen.

When I use ign gazebo.sdf -v I get the following

[Msg] Ignition Gazebo Server v5.3.0
[Msg] Ignition Gazebo GUI    v5.3.0
[Msg] Loading SDF world file[/usr/share/ignition/ignition-gazebo5/worlds/shapes.sdf].
[Msg] Loaded level [3]
[Msg] No systems loaded from SDF, loading defaults
[Msg] Create service on [/world/shapes/create]
[Msg] Remove service on [/world/shapes/remove]
[Msg] Pose service on [/world/shapes/set_pose]
[Msg] Light configuration service on [/world/shapes/light_config]
[Msg] Physics service on [/world/shapes/set_physics]
[Msg] Enable collision service on [/world/shapes/enable_collision]
[Msg] Disable collision service on [/world/shapes/disable_collision]
[Msg] Material service on [/world/shapes/visual_config]
[Msg] Serving world controls on [/world/shapes/control] and [/world/shapes/playback/control]
[Msg] Serving GUI information on [/world/shapes/gui/info]
[Msg] World [shapes] initialized with [default_physics] physics profile.
[Msg] Serving world SDF generation service on [/world/shapes/generate_world_sdf]
[Msg] Serving world names on [/gazebo/worlds]
[Msg] Resource path add service on [/gazebo/resource_paths/add].
[Msg] Resource path get service on [/gazebo/resource_paths/get].
[Msg] Resource paths published on [/gazebo/resource_paths].
[GUI] [Wrn] [Application.cc:669] [QT] file:///usr/lib/x86_64-linux-gnu/qt5/qml/QtQuick/Dialogs/DefaultFileDialog.qml:102:33: QML Settings: Failed to initialize QSettings instance. Status code is: 1
[GUI] [Wrn] [Application.cc:669] [QT] file:///usr/lib/x86_64-linux-gnu/qt5/qml/QtQuick/Dialogs/DefaultFileDialog.qml:102:33: QML Settings: The following application identifiers have not been set: QVector("organizationName", "organizationDomain")
[GUI] [Wrn] [Application.cc:669] [QT] file:///usr/lib/x86_64-linux-gnu/qt5/qml/QtQuick/Dialogs/DefaultFileDialog.qml:102:33: QML Settings: Failed to initialize QSettings instance. Status code is: 1
[GUI] [Wrn] [Application.cc:669] [QT] file:///usr/lib/x86_64-linux-gnu/qt5/qml/QtQuick/Dialogs/DefaultFileDialog.qml:102:33: QML Settings: The following application identifiers have not been set: QVector("organizationName", "organizationDomain")
[GUI] [Wrn] [Application.cc:669] [QT] file::/Gazebo/GazeboDrawer.qml:147:3: QML Dialog: Binding loop detected for property "implicitHeight"
[GUI] [Wrn] [Application.cc:669] [QT] file:///usr/lib/x86_64-linux-gnu/qt5/qml/QtQuick/Dialogs/DefaultFileDialog.qml:102:33: QML Settings: Failed to initialize QSettings instance. Status code is: 1
[GUI] [Wrn] [Application.cc:669] [QT] file:///usr/lib/x86_64-linux-gnu/qt5/qml/QtQuick/Dialogs/DefaultFileDialog.qml:102:33: QML Settings: The following application identifiers have not been set: QVector("organizationName", "organizationDomain")
[GUI] [Wrn] [Application.cc:669] [QT] file::/Gazebo/GazeboDrawer.qml:147:3: QML Dialog: Binding loop detected for property "implicitHeight"
[Msg] Found no publishers on /stats, adding root stats topic
[Msg] Found no publishers on /clock, adding root clock topic
[Msg] Serving scene information on [/world/shapes/scene/info]
[Msg] Serving graph information on [/world/shapes/scene/graph]
[Msg] Serving full state on [/world/shapes/state]
[Msg] Serving full state (async) on [/world/shapes ...
(more)
edit retag flag offensive close merge delete

Comments

I'm facing the same issue, but I've installed it from source. But I already have a gazebo11 binary installed, do you have a similar situation?

MhAyman gravatar imageMhAyman ( 2022-02-23 06:06:43 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2023-08-03 23:16:22 -0500

I faced a very similar issue with gazebo citadel on Ubuntu 20.04. Turning off the firewall with sudo ufw disable solved the issue for me but this is only a temporary solution. I suppose by default the ignition gazebo server used my devices LAN IP to listen for incoming client requests, which is why the firewall blocked it. In any case, shifting the address to local loopback i.e. 127.0.0.1 with export IGN_IP=127.0.0.1 is better than disabling the firewall, provided you want to run both server and client on the same machine.

edit flag offensive delete link more
0

answered 2022-02-23 09:55:18 -0500

MhAyman gravatar image

After running with ign gazebo.sdf -v 4 it turned out it was an ignition transport issue, which I then solved by resting my firewall because it was blocking multicast.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2022-01-06 02:51:47 -0500

Seen: 668 times

Last updated: Feb 23 '22