Gazebo | Ignition | Community
Ask Your Question
0

Ignition:12.0.0~pre1: Blank screen on running any "ign gazebo actor.sdf -v 4" like command.

asked 2022-01-24 16:30:02 -0500

hitesh gravatar image

I am new to robotics . I recently installed ignition on my ubuntu following all steps mentioned in https://ignitionrobotics.org/docs/gar...

All command were successful , but when i run "ign gazebo actor.sdf -v 4" or "ign gazebo actor.sdf -v 4" it opens blank screen. On terminal it keep on writing- [Dbg] [CameraSensor.cc:524] Camera info for [camera::link::camera] advertised on [/camera_info] [GUI] [Dbg] [Gui.cc:156] GUI requesting list of world names. The server may be busy downloading resources. Please be patient. [GUI] [Dbg] [Gui.cc:156] GUI requesting list of world names. The server may be busy downloading resources. Please be patient. [GUI] [Dbg] [Gui.cc:156] GUI requesting list of world names. The server may be busy downloading resources. Please be patient.

ign service -l does not return anything.

edit retag flag offensive close merge delete

Comments

This question is stuck in "This post is awaiting moderation" ...What does that mean ?

hitesh gravatar imagehitesh ( 2022-01-25 08:18:35 -0500 )edit

Ogre2 logs shows this : 19:48:15: Creating resources for group Internal 19:48:15: All done 19:48:15: Added resource location '/home/emathit/workspace/install/share/ignition/ignition-rendering7/media/materials/textures/' of type 'FileSystem' to resource group 'General' 19:48:15: Can't assign material scene::Material(65519) because this Material does not exist. Have you forgotten to define it in a .material script? 19:48:15: Can't assign material scene::Material(65513) because this Material does n

hitesh gravatar imagehitesh ( 2022-01-25 12:32:55 -0500 )edit

Can someone help..I am still facing the same error...tried installing multiple times

hitesh gravatar imagehitesh ( 2022-02-05 04:20:18 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-02-23 09:56:35 -0500

MhAyman gravatar image

I solved it by resting my firewall because it was blocking multicast, which was preventing ign transport from working properly.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2022-01-24 16:30:02 -0500

Seen: 133 times

Last updated: Feb 23