Gazebo | Ignition | Community
Ask Your Question

Plugin/SDF problem; unable to find or open sdf file

asked 2013-05-12 15:33:05 -0500

bot gravatar image

Hello, I am trying to create my first Gazebo plugin. I tried to follow this tutorial - link, and this is the result (Gazebo was installed as pre-compiled binaries on Ubuntu 12.04.):

Gazebo multi-robot simulator, version 1.6.1 Copyright (C) 2013 Open Source Robotics Foundation. Released under the Apache 2 License.

Error [] Unable to find or open SDF file[] Error [] Unable to initialize sdf

edit retag flag offensive close merge delete


Having the same error while executing: gzsdf print model.urdfError [] Unable to find or open SDF file[]

Davinci gravatar imageDavinci ( 2013-05-13 09:32:06 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-05-13 13:57:24 -0500

bot gravatar image

I am going to answer my own question :). I forgot this part of installation: quick start. This line solved problem for me:

source /usr/share/gazebo[version]/
edit flag offensive delete link more
Login/Signup to Answer

Question Tools



Asked: 2013-05-12 15:33:05 -0500

Seen: 2,199 times

Last updated: May 13 '13