getting "SpawnModel: Failure - model name turtlebot3_waffle already exist". whenevr I launch any turtlebot3 launch file and the same world file loads regardless of which one I run

asked 2022-06-10 21:41:11 -0500

gman9500 gravatar image

Ubuntu 20.04 LTS Ros Noetic gazebo version 11.10.2

Hi there!. So I got the turtlebot3 package installed and ran it once with roslaunch turtlebot3_gazebo turtlebot3_world.launch and gazebo started up fine no errors/ I decided to try the other worlds And that's when I started getting errors displayed specifically SpawnModel: Failure - model name turtlebot3_waffle already exist. also get ERROR] [1654909866.855966, 4157.283000]: Spawn service failed. Exiting. [gazebo-1] process has died [pid 44505, exit code 255, cmd /opt/ros/noetic/lib/gazebo_ros/gzserver -e ode /home/xx/catkin_turtlebot/src/turtlebot3_simulations/turtlebot3_gazebo/worlds/turtlebot3_world.world __name:=gazebo __log:=/home/dg/.ros/log/a262cbb6-e919-11ec-b235-c7e9fb4ba842/gazebo-1.log]. log file: /home/xx/.ros/log/a262cbb6-e919-11ec-b235-c7e9fb4ba842/gazebo-1*.log

[spawn_urdf-3] process has died [pid 44515, exit code 1, cmd /opt/ros/noetic/lib/gazebo_ros/spawn_model -urdf -model turtlebot3_waffle_pi -x -2.0 -y -0.5 -z 0.0 -param robot_description __name:=spawn_urdf __log:=/home/xx/.ros/log/a262cbb6-e919-11ec-b235-c7e9fb4ba842/spawn_urdf-3.log]. log file: /home/xx/.ros/log/a262cbb6-e919-11ec-b235-c7e9fb4ba842/spawn_urdf-3*.log

and even if I launch the empty world launch file or the house launch file it always launch the regular world file and now there's 3 robots in it but they have different names, Also gazebo itself no launches by itself if I just type in gazebo at the command prompt to just start a blank gazebo. Before it worked fine until I installed turtlebot3 package. Now it does nothing . never starts. Though it will start via the turtbot3 launch files, just errors out with SPawnModel failure and has 3 robots in the world and always launches the same world file regardless if of which one I choose

If I do rosrun gazebo_ros gazebo on the cmd line, that launches gazebo just fine, but instead of a blank world I get the turtlebot3_world loaded with 3 different robots loaded. What am I missing thats causing this?

note: I see a similar issue was posted a few years ago, but it didn't specify the model and I"ve not changed any config files to give 2 robots the same name. I"m just tryign to run the pre done packages.

I did set the model env variable before starting with the export command .

edit retag flag offensive close merge delete