Unable to install Ignition Gazebo on Ubuntu 22.04 - Missing package

asked 2022-07-17 14:33:50 -0600

Messiah gravatar image

I am following a ROS2 tutorial https://docs.ros.org/en/humble/Tutori... which states that I should install Ignition Gazebo. So I use https://gazebosim.org/docs/garden/ins... to install Ignition Garden with ign-gazebo7.x from source but run into the following error on the very first command (sudo apt install python3-pip wget lsb-release gnupg curl):


Ign:1 http://packages.ros.org/ros/ubuntu jammy InRelease │ Hit:2 http://security.ubuntu.com/ubuntu jammy-security InRelease │ Hit:3 http://packages.ros.org/ros2/ubuntu jammy InRelease │ Hit:4 http://archive.ubuntu.com/ubuntu jammy InRelease │ Err:5 http://packages.ros.org/ros/ubuntu jammy Release │ 404 Not Found [IP: 64.50.236.52 80] │ Hit:6 http://packages.osrfoundation.org/gaz... jammy InRelease │ Hit:7 http://archive.ubuntu.com/ubuntu jammy-updates InRelease │ Reading package lists... Done │ E: The repository 'http://packages.ros.org/ros/ubuntu jammy Release' does not have a Release file. │ N: Updating from such a repository can't be done securely, and is therefore disabled by default. │ N: See apt-secure(8) manpage for repository creation and user configuration details. │ Reading package lists... Done │ Building dependency tree... Done │ Reading state information... Done │ lsb-release is already the newest version (11.1.0ubuntu4). │ wget is already the newest version (1.21.2-2ubuntu1). │ gnupg is already the newest version (2.2.27-3ubuntu2.1). │ You might want to run 'apt --fix-broken install' to correct these. │ The following packages have unmet dependencies: │ libignition-gazebo-plugins : Depends: libignition-plugin1-1 (>= 1.2.1+ds) but it is not going to be install│ ed │ libignition-gazebo6-6 : Depends: libignition-plugin1-1 (>= 1.2.1+ds) but it is not going to be installed │ libignition-gui6-6 : Depends: libignition-plugin1-1 (>= 1.2.1+ds) but it is not going to be installed │ libignition-rendering6-6 : Depends: libignition-plugin1-1 (>= 1.2.1+ds) but it is not going to be installed Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


It states near the end that there is a missing dependency, namely libignition-plugin1-1. When I try to apt install this directory, I get another error:


Reading package lists... Done │ Building dependency tree... Done │ Reading state information... Done │ Suggested packages: │ ignition-tools │ The following NEW packages will be installed: │ libignition-plugin1-1 │ 0 upgraded, 1 newly installed, 0 to remove and 84 not upgraded. │ 392 not fully installed or removed. │ Need to get 0 B/43.6 kB of archives. │ After this operation, 144 kB of additional disk space will be used. │ (Reading database ... 124396 files and directories currently installed.) │ Preparing to unpack .../libignition-plugin1-1_1.2.1+ds-1_amd64.deb ... │ Unpacking libignition-plugin1-1:amd64 (1.2.1+ds-1) ... │ dpkg: error processing archive /var/cache/apt/archives/libignition-plugin1-1_1.2.1+ds-1_amd64.deb (--unpack)│ : │ trying to overwrite '/usr/lib/x86_64-linux-gnu/libignition-plugin1-loader.so.1.2.1', which is also in packa│ ge libignition-plugin:amd64 1.2.1+osrf-1~jammy │ Errors were encountered while processing: │ /var/cache/apt/archives/libignition-plugin1-1_1.2.1+ds-1_amd64.deb │ E: Sub-process /usr/bin/dpkg returned an error code (1)


I am not sure what this error is referring to exactly, so I ... (more)

edit retag flag offensive close merge delete