Gazebo | Ignition | Community
Ask Your Question
0

Not able to run spawn_urdf tutorial with Garden

asked 2022-09-16 02:39:52 -0500

radiantb gravatar image

updated 2022-09-18 13:17:04 -0500

I am not able to run gz service -l. I wasn't sure if this is a bug, so I thought of putting this here. When I run gz sim empty.sdf I get following warnings in my terminal

libEGL warning: DRI2: failed to create dri screen
libEGL warning: DRI2: failed to create dri screen

Then in another terminal when I run gz service -l, I get the following output

The 'gz' command provides a command line interface to the Gazebo Tools.

  gz <command> [options]

    List of available commands:

  help:          Print this help text.
  gui:           Launch graphical interfaces.
  fuel:          Manage simulation resources.


     sim:           Run and manage the Gazebo Simulator.
      gazebo:        Deprecated. Alias for sim.
      sdf:           Utilities for SDF files.
      model:         Print information about models.
      plugin:        Print information about plugins.
      msg:           Print information about messages.
      log:           Record or playback topics.

Options:

  --force-version <VERSION>  Use a specific library version.
  --versions                 Show the available versions.
  --commands                 Show the available commands.
Use 'gz help <command>' to print help for a command.

I face a similar output when I try to run commands related to gz topic too

Environment: OS: Ubuntu 20.04 Build: Binary Garden Installation GPU details:

Fri Sep 16 13:07:38 2022       
+-----------------------------------------------------------------------------+

| NVIDIA-SMI 515.65.01    Driver Version: 515.65.01    CUDA Version: 11.7     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   55C    P8    N/A /  N/A |      9MiB /  3072MiB |      0%      Default |

|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A       936      G   /usr/lib/xorg/Xorg                  4MiB |
|    0   N/A  N/A      1462      G   /usr/lib/xorg/Xorg                  4MiB |
+-----------------------------------------------------------------------------+
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2022-09-23 09:55:43 -0500

Carlos Agüero gravatar image

Thanks! This should be fixed in the next prerelease after this patch.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2022-09-16 02:39:52 -0500

Seen: 32 times

Last updated: Sep 23