Gazebo dies when using in a remote virtual machine through remote desktop like X2Go

asked 2022-09-22 17:27:09 -0600

Hello all. I have been allotted a remote virtual machine (running Ubuntu 20.04) from my university, where I installed ROS Noetic desktop full as shown in their installation instructions. I use the virtual machine by logging in through X2Go Remote desktop (this part will be important in just a minute).

To test my installation I just tried to launch gazebo (both via rosrun and via roslaunch) but it tries to launch for half a second and always dies.

Here are the three ways I tried to launch it and the error that it shows when it fails:

  1. roslaunch: I created a simple launch file that contains only one line: to include the gazebo_ros empty world. It looks like this <include file="$(find gazebo_ros)/launch/empty_world.launch" />. The main error in the terminal output is this: Segmentation fault (core dumped) [gazebo_gui-2] process has died [pid 12821, exit code 139 The whole error message is here, as I could not paste the error message on text properly. image description What's more annoying is that it says the error has been written to the log file gazebo-gui-2*.log file, when in reality this file does not exist at all.
  2. launching gzserver and gzclient with verbose option. Also fails in this case. Terminal output for both: image description
  3. Using rosrun gazebo_ros for gzserver and gzclient in separate terminals. In this case there is an added bit of information that shows up only when I try to rosrun gzclient and it fails, which is: "Reason given for shutdown: [[/gazebo] Reason: new node registered with same name]" image description

The weird part here is that when I SSH into the virtual machine from my WSL terminal and then run the above commands it somehow works. Though, the GUI loads so slowly, that it is practically useless for any real usage (the VM is in a different city).

This answer on ROS forum says I need NVIDIA graphics card. This is not possible for me to obtain on a university VM.

Additionally, for some people here and here it seems to have worked by "turning it off and on" a few times. That did not work for me.

I really feel like at the end of the rope. Any help would be appreciated. Many thanks in advance.

edit retag flag offensive close merge delete