How to download Gazebo on Ubuntu

asked 2022-11-22 04:47:39 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi , I’m a beginner in ros and gazebo. I try to download gazebo in ubuntu 20.4 and ros2 I use is humble. I have below error when try to follow the tutorial. I try some way suggest on github but it not solve the issue. Could you guy give me the advice or solution to fix this issue please?

sudo apt -y install \ $(sort -u $(find . -iname 'packages-'lsb_release -cs'.apt' -o -iname 'packages.apt' | grep -v '/.git/') | sed '/gz\|sdf/d' | tr '\n' ' ')

Here is the error :

Reading package lists... Done

Building dependency tree... Done

Reading state information... Done

E: Unable to locate package libogre-next-2.3-dev

E: Couldn't find any package by glob 'libogre-next-2.3-dev

edit retag flag offensive close merge delete