Gazebo | Ignition | Community
Ask Your Question

Error running "ign gazebo" from tutorial

asked 2022-12-09 03:56:49 -0600

Vol gravatar image

Ubuntu 22.04. I’ve installed gazebo garden using Binary installation on Ubuntu instructions from this page:

Then when I run the command "ign gazebo" I get the following response: "Command 'ign' not found, but can be installed with: sudo apt install ignition-tools".

After installation of "ignition-tools" I get the following error: "I cannot find any available 'ign' command: * Did you install any ignition library? * Did you set the IGN_CONFIG_PATH environment variable? E.g.: export IGN_CONFIG_PATH=$HOME/local/share/ignition"

I also tried to install "libignition-gazebo" from this page: - no luck.

What is this "ign" command, and how can I install it?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2022-12-16 08:42:06 -0600

alex-ssom gravatar image

If you're using Gazebo Garden. You should use the Garden version of the tutorials.

The ign gazebo command was deprecated in favor of gz sim

See: for details on this migration.

TL;DR use gz sim shapes.sdf

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2022-12-09 03:56:49 -0600

Seen: 549 times

Last updated: Dec 16 '22