Gazebo | Ignition | Community
Ask Your Question
0

Ignition gazebo citadel can no longer load worlds from fuel.gazebosim.org

asked 2023-01-09 07:10:46 -0600

GuillaumeB gravatar image

updated 2023-01-09 07:11:19 -0600

In a fresh Ubuntu 20.04 VM with Ignition Gazebo citadel, version 3.14.0 installed, I cannot load worlds from fuel.gazebosim.org.

Previously I was able to do so.

For example: ign gazebo "https://fuel.gazebosim.org/1.0/OpenRobotics/worlds/Test_shapes" was properly starting gazebo and loading the world (I could also do it with more complex worlds like the Tugbot_warehouse).

This command no longer works. Now this command gives:

[Err] [Server.cc:181] Error Code 13 Msg: Directory doesn't exist[/home/ubuntu/.ignition/fuel/fuel.ignitionrobotics.org/openrobotics/models/ground plane/tip] [Err] [Server.cc:181] Error Code 13 Msg: Directory doesn't exist[/home/ubuntu/.ignition/fuel/fuel.ignitionrobotics.org/openrobotics/models/sun/tip]

And the same is happening with any other world from fuel that I tried. For every model, the "tip" folder is missing.

Is Gazebo Citadel still expected to work with Fuel? What would be the way to load Fuel worlds from Gazebo Citadel?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2023-01-12 23:10:06 -0600

azeey gravatar image

This is a bug in Gazebo which should be fixed by https://github.com/gazebosim/gz-fuel-...

edit flag offensive delete link more
0

answered 2023-01-12 13:10:12 -0600

alex-ssom gravatar image

updated 2023-01-12 13:10:34 -0600

I ran into the same issue on Gazebo Fortress. The easiest way I found to fix this was to download the content locally. image description

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2023-01-09 07:10:46 -0600

Seen: 44 times

Last updated: Jan 12