Gazebo | Ignition | Community
Ask Your Question

failing to build gazebo from source due to not being able to download libraries.

asked 2023-03-20 16:22:57 -0500

ryn gravatar image

updated 2023-03-20 16:23:11 -0500


Im trying to build gazebo from source for the gz-sim github:

from this tutorial linked in the github:

but when I get to the part where you install the libraries, this is what I get:

sudo apt -y install   $(sort -u $(find . -iname 'packages-'`lsb_release -cs`'.apt' -o -iname 'packages.apt' | grep -v '/\.git/') | sed '/ignition\|sdf/d' | tr '\n' ' ')
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Unable to locate package libgz-fuel-tools9-dev
    E: Unable to locate package libgz-gui8-dev
    E: Unable to locate package libgz-msgs10-dev
    E: Unable to locate package libgz-rendering8-dev
    E: Unable to locate package libgz-sensors8-dev
    E: Unable to locate package libgz-transport13-dev

what am I missing?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2023-03-22 11:16:01 -0500

ryn gravatar image

I figured it out now. I had two problems.

Firstly, Its confusing knowing what gazebo version to use with what ros2 version. and which one to use isn't immediately obvious. Following the below guide, I saw that my version of ROS2(foxy), only supported citadel.

(or if that link is dead, if you're using an LTS ROS2 version(foxy), use gazebo(citadel), or if you're using the latest ROS2, use the latest version of gazebo(garden)

Second, I found the install from source guide for Ubuntu + gazebo citadel here:

edit flag offensive delete link more

answered 2023-03-21 10:58:32 -0500

azeey gravatar image

Looks like you either haven't added the repository or ran sudo apt-get update afterwards.

Can you try running this section taken from the tutorial you linked:

sudo sh -c 'echo "deb `lsb_release -cs` main" > /etc/apt/sources.list.d/gazebo-stable.list'
wget -O - | sudo apt-key add -
sudo apt-get update
edit flag offensive delete link more


I ran those commands, and it still didn't work. I got the same error again. Is there a place to install these libraries from source?

ryn gravatar imageryn ( 2023-03-21 13:29:59 -0500 )edit

You can find more instructions, including how to build from source at

azeey gravatar imageazeey ( 2023-03-21 21:51:52 -0500 )edit

Question Tools

1 follower


Asked: 2023-03-20 16:22:57 -0500

Seen: 193 times

Last updated: Mar 22