Gazebo | Ignition | Community
Ask Your Question
0

fuel.gazebosim.org down or deprecated?

asked 2023-03-22 05:45:11 -0500

jrtg gravatar image

Hello,

I am trying to run the ROS / Gazebo tutorial.

So I downloaded visualize_lidar.sdf and run as instructed:

ign gazebo -v 4 -r visualize_lidar.sdf

Small issue: there's an error message:

Error [Converter.cc:156] Unable to convert from SDF version 1.10 to 1.9

I "fixed" this by changing the version in the sdf file to 1.9.

Main issue:

This part of the sdf file fails:

<include>
  <pose>0 0 0 0 0 1.57</pose>
  <uri>https://fuel.gazebosim.org/1.0/openrobotics/models/Playground</uri>
</include>

which is obvious as https://fuel.gazebosim.org/ returns 404 page not found.

--> Is this a temporary issue? Or is fuel.gazebosim.org deprecated?

I found the model on https://app.gazebosim.org/ and tried to change the sdf file as follows, but that doesn't work either:

<include>
  <pose>0 0 0 0 0 1.57</pose>
  <uri>https://app.gazebosim.org/OpenRobotics/fuel/models/Playground</uri>
</include>

Fails with following error:

`[Err] [Server.cc:139] Error Code 13: [/sdf/world[@name="visualize_lidar_world"]/include[0]/uri:/home/johan/gazebo_test/src/tutorial/visualize_lidar.sdf:L516]: Msg: Unable to find uri[https://app.gazebosim.org/OpenRobotics/fuel/models/Playground]`
edit retag flag offensive close merge delete

Comments

Can you tell us what version of Gazebo you're using? Also, https://fuel.gazebosim.org/ is the correct url. It returns a 404 when using a web browser, but if you go to https://fuel.gazebosim.org/1.0/openro..., it'll respond with some data.

azeey gravatar imageazeey ( 2023-03-22 16:10:29 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2023-03-23 04:58:55 -0500

jrtg gravatar image

updated 2023-03-23 08:17:30 -0500

Can you tell us what version of Gazebo you're using?

It's Ignition Gazebo Fortress, installed from packages on an Ubuntu 22.04 in a virtualbox on Windows.

Today it does load the model, so I think this must have been a temporary server-side issue (I'm fairly sure I also got the 404 with the full path).

It still doesn't work though (complains about several libraries not found).

In the mean time I have compiled Gazebo Garden and Rolling from source, as well as the ros_gz_bridge (and for the latter also gps_msgs).

This seems to work, except that the bridge errors:

[WARN] [1679564767.107537388] [ros_gz_bridge]: Failed to create a bridge for topic [/model/vehicle_blue/cmd_vel] with ROS2 type [geometry_msgs/msg/Twist] to topic [/model/vehicle_blue/cmd_vel] with Gazebo Transport type [ignition.msgs.Twist]

This seems rather obvious, as there is no topic cmd_vel? Although it's not listed in the official tutorial either?

ign topic -l
/clock
/gazebo/resource_paths
/gui/camera/pose
/model/vehicle_blue/odometry
/model/vehicle_blue/tf
/stats
/world/visualize_lidar_world/clock
/world/visualize_lidar_world/dynamic_pose/info
/world/visualize_lidar_world/pose/info
/world/visualize_lidar_world/scene/deletion
/world/visualize_lidar_world/scene/info
/world/visualize_lidar_world/state
/world/visualize_lidar_world/stats`

EDIT: I learned that:

  1. Contrary to ROS 2, topics that have listeners only are not shown in gz topic -l. This will thankfully be fixed soon.

  2. Obviously the bridge command failed, as ignition.msgs.Twist has been renamed to gz.msgs.Twist.

It is working now, thank you.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2023-03-22 05:45:11 -0500

Seen: 1,754 times

Last updated: Mar 23 '23