Gazebo | Ignition | Community
Ask Your Question
0

ROS2 Gazebo captures pointcloud in the sky using the depth camera.

asked 2023-04-02 04:18:29 -0600

IgararA gravatar image

image description image description
I tried to use the Gazebo depth camera plugin in ROS2 Humble and Gazebo-11.10.2, but I noticed that it seems to capture Pointcloud data in the sky from the camera's perspective. Is this normal? To confirm if this is a normal occurrence, I tried modifying the waffle-related SDF file in turtlebot3_gazebo to see if the same phenomenon occurs. However, I also saw other projects on GitHub that are able to correctly exclude the sky point cloud data from the topic. I tried running the SDF and URDF files from the link by modifying the launch file, but still got the same results. I couldn't find any relevant information by searching the forums using keywords such as "sky point cloud." Can anyone provide an explanation for this? I apologize if I haven't described the problem clearly enough.

I added the files model_realsense.sdf and turtlebot3_waffle_realsense.urdf from the provided link into the "models" and "urdf" folders of "turtlebot3_gazebo".

├── turtlebot3_waffle  
│   ├── model-1_4.sdf  
│   ├── model.config  
│   ├── model_realsense.sdf  
│   └── model.sdf  
.
├── common_properties.urdf  
├── turtlebot3_burger.urdf  
├── turtlebot3_waffle_pi.urdf  
├── turtlebot3_waffle_realsense.urdf  
└── turtlebot3_waffle.urdf

I then modified the file paths of the SDF and URDF files in the spawn_turtlebot3.launch.py and robot_state_publisher.launch.py files to successfully load the files from the link. However, the simulation still did not run as expected based on the results shown in the project image. Below is the modification I made by only changing the SDF file without modifying other contents of turtlebot3_gazebo. The frame_name is already represented in the original URDF file.

  <sensor name="intel_realsense_r200_depth" type="depth">
    <always_on>1</always_on>
    <update_rate>1</update_rate>
    <pose>0.064 -0.047 0.107 0 0 0</pose>
    <camera name="realsense_depth_camera">
    </camera>
    <plugin name="intel_realsense_r200_depth_driver" filename="libgazebo_ros_camera.so">
        <camera_name>intel_realsense_r200_depth</camera_name>
        <frame_name>camera_depth_frame</frame_name>
        <hack_baseline>0.07</hack_baseline>
        <min_depth>0.001</min_depth>
      </plugin>
  </sensor>
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2023-04-04 19:23:40 -0600

IgararA gravatar image

I solved this problem by changing workspace from virtual machine Ubuntu22.04 to real Ubuntu22.04.My problem is same as this link,but it does not work for me. I infer that this is a problem of graphical driver or compatibility of gazebo_ros_pkgs plugin .

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2023-04-02 04:18:29 -0600

Seen: 948 times

Last updated: Apr 04 '23