Gazebo | Ignition | Community
Ask Your Question

How to fix Gazebo black screen on launch?

asked 2023-04-03 20:04:01 -0600

AlexL gravatar image

Whenever I launch Gazebo, the application will launch but the center of the screen is only black. It came installed with ROS2 Humble and it didn't work out of the box. I am using Ubuntu WSL from the Microsoft webstore. My Gazebo version is version 11.10.2.

I have seen others have a fix for this issue but I have tried all of them and nothing has fixed the problem. Some of the fixes I have tried include:

  • export GAZEBO_IP=
  • Installing VcXsrv and following the steps on (Unless I am doing something wrong with this)
  • Uninstalling and reinstalling Gazebo
  • Restarting computer
  • Restarting WSL
  • gazebo --verbose
  • Trying different GPUs
  • colcon build

And more I haven't thought of.

Things to note

  • I can run Gazebo fine in other versions like 20.04 without any problem.
  • Whenever I tried to first launch Gazebo on my computer, my computer screen started to completely glitch out, even when I ended the program and exited out of everything.
  • glxgears runs fine

I am following this tutorial and everything has been fine up until this point: I understand that the tutorial is using foxy and I have just changed the distros to "humble" but I am not sure if this is what could be causing the error.

I call Gazebo with the following command as per the tutorial:

ros2 launch gazebo_ros

I don't know what else to do here. I am stuck and I can't progress any further in this. I am fairly new at this so I might be missing a simple oversight. Any help that you can give would be greatly appreciated.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2023-05-04 07:56:37 -0600

I have very similar issue.

were you able to fix it somehow please?

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2023-04-03 20:04:01 -0600

Seen: 339 times

Last updated: Apr 03