Gazebo | Ignition | Community
Ask Your Question
0

Unable to install Gazebo on MacOS Ventura

asked 2023-04-19 05:07:06 -0500

janto gravatar image

Hi there,

i am running a MacBook Pro with the M1 Pro Chip and Ventura.

I followed this Tutorial to install the binaries of Gazebo on MacOS Binary Installation on MacOS.

I always end up with the same error. Here is a snippet from the command prompt. This snippet starts after many packages have been downloaded

 ...   
==> Installing osrf/simulation/gz-garden dependency: gz-common5
==> cmake .. -DBUILD_TESTING=Off -DCMAKE_INSTALL_RPATH=@loader_path/../lib
==> make install
Last 15 lines from /Users/jantoehr/Library/Logs/Homebrew/gz-common5/02.make:
[ 81%] Building CXX object graphics/src/CMakeFiles/gz-common5-graphics.dir/Skeleton.cc.o
...
# There were many many lines of logs here which I excluded for readability purposes 
...
[ 87%] Built target gz-common5-graphics
[ 87%] Built target doc
make: *** [all] Error 2

If reporting this issue please do so at (not Homebrew/brew or Homebrew/homebrew-core):
  https://github.com/osrf/homebrew-simulation/issues

Did anyone on MacOS encounter the same issue and was able to resolve it?

I would appreciate any kind of help :)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2023-07-25 06:32:36 -0500

PButov gravatar image

Hi, have you solved this issue? I have the same problem on my Apple M1 Ventura 13.3.1

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2023-04-19 05:07:06 -0500

Seen: 225 times

Last updated: Apr 19 '23