gzserver dies with "Illegal instruction" when using plugin

asked 2023-05-04 06:37:31 -0500


I'm new to ROS and Gazebo. I've tried using this plugin for the realsense camera in gazebo:


I've followed the instructions as described in the readme. The workspace builds successfully, but when I use roslaunch the gazebo process dies right after spawning the urdf.

I also tried using the original plugin from PAL-Robotics but the behavior was the same.

Here is some additional information:

roslaunch Output:

started roslaunch server http://user-desktop:37871/



 * /gazebo/enable_ros_network: True
 * /robot_description: <?xml version="1....
 * /robot_state_publisher/publish_frequency: 30.0
 * /rosdistro: noetic
 * /rosversion: 1.16.0
 * /use_gui: True
 * /use_sim_time: True


gazebo (gazebo_ros/gzserver)
gazebo_gui (gazebo_ros/gzclient)
robot_state_publisher (robot_state_publisher/robot_state_publisher)
rviz (rviz/rviz)
urdf_spawner (gazebo_ros/spawn_model)

auto-starting new master
process[master]: started with pid [11573]

setting /run_id to b1e6c97a-e828-11ed-afc9-b5f2584541b8
process[rosout-1]: started with pid [11583]
started core service [/rosout]
process[robot_state_publisher-2]: started with pid [11586]
process[gazebo-3]: started with pid [11587]
process[gazebo_gui-4]: started with pid [11589]
process[urdf_spawner-5]: started with pid [11595]
process[rviz-6]: started with pid [11603]
[INFO] [1682949712.645824, 0.000000]: Loading model XML from ros parameter robot_description
[INFO] [1682949712.694653, 0.000000]: Waiting for service /gazebo/spawn_urdf_model
[INFO] [1682949724.284146171]: Finished loading Gazebo ROS API Plugin.
[INFO] [1682949724.332086997]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
[INFO] [1682949725.074329041]: Finished loading Gazebo ROS API Plugin.
[INFO] [1682949725.077292391]: waitForService: Service [/gazebo_gui/set_physics_properties] has not been advertised, waiting...
[INFO] [1682949727.837939, 0.000000]: Calling service /gazebo/spawn_urdf_model
[INFO] [1682949727.839696055]: waitForService: Service [/gazebo/set_physics_properties] is now available.
[INFO] [1682949729.097726, 0.001000]: Spawn status: SpawnModel: Successfully spawned entity
[INFO] [1682949729.102076, 0.001000]: Unpausing physics
[INFO] [1682949729.140187056, 0.001000000]: Physics dynamic reconfigure ready.
[INFO] [1682949729.397690225, 0.001000000]: Realsense Gazebo ROS plugin loading.

RealSensePlugin: The realsense_camera plugin is attach to model robot

[urdf_spawner-5] process has finished cleanly
log file: /home/user/.ros/log/b1e6c97a-e828-11ed-afc9-b5f2584541b8/urdf_spawner-5*.log

**Illegal instruction (core dumped)**

**[gazebo-3] process has died** [pid 11587, exit code 132, cmd /opt/ros/noetic/lib/gazebo_ros/gzserver -e ode worlds/empty.world __name:=gazebo __log:=/home/user/.ros/log/b1e6c97a-e828-11ed-afc9-b5f2584541b8/gazebo-3.log].
log file: /home/user/.ros/log/b1e6c97a-e828-11ed-afc9-b5f2584541b8/gazebo-3*.log


CPU: AMD Athlon II X4 640 Processor
Memory: 4017MB 
Type: Desktop
OS: Ubuntu 20.04.6 LTS
GPU: AMD CEDAR (DRM 2.50.0 / 5.15.0-71-generic, LLVM 12.0.0), Memory 4017656kiB


Linux user-desktop 5.15.0-71-generic #78~20.04.1-Ubuntu SMP Wed Apr 19 11:26:48 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

Gazebo version 11.11.0

edit retag flag offensive close merge delete