Gazebo shows black screen where robot model should be

asked 2023-05-04 07:50:21 -0500

Whenever I launch Gazebo, the application will launch but the center of the screen where robot model should be is only black. I am using WSL2 with Ubuntu 20.06.04 LTS to run it, gazebo version is 11.12.0. I am also using VcXsrv XLaunch to open it with windows GUI.

To run it, i enter the following commands:

export GAZEBO_IP=

export DISPLAY=$(cat /etc/resolv.conf | grep nameserver | awk '{print $2}'):0


gazebo --verbose

It worked about 3 month ago, but now it does not

possibly interesting things:

  1. When i run gazebo --verbose /opt/ros/foxy/share/gazebo_plugins/worlds/, it is black, but operations in the background like moving are running
  2. When I try to launch Gazebo on my computer, my computer screen startes to completely glitch out (going black for a split second)
  3. glxgears runs fine

Does somebody know how to fix it please?

image description

edit retag flag offensive close merge delete