Gazebo | Ignition | Community
Ask Your Question

gazebo_ros_pkgs - Erro.

asked 2013-07-01 17:40:06 -0500

EduardoMaciel gravatar image

updated 2013-07-01 18:06:05 -0500

nkoenig gravatar image

When I do the downloading

cd ~ / catkin_ws / src

git clone

the following error occurs when used the catkin_make.

Linking CXX shared library /home/orbit/catkin_ws/devel/lib/
[ 95%] Built target gazebo_ros_depth_camera
Scanning dependencies of target gazebo_ros_paths_plugin
[ 96%] Building CXX object gazebo_ros_pkgs/gazebo_ros/CMakeFiles/gazebo_ros_paths_plugin.dir/src/gazebo_ros_paths_plugin.cpp.o
/home/orbit/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/src/gazebo_ros_api_plugin.cpp: In destructor ‘virtual gazebo::GazeboRosApiPlugin::~GazeboRosApiPlugin()’:
/home/orbit/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/src/gazebo_ros_api_plugin.cpp:43:3: error: ‘DisconnectSigInt’ is not a member of ‘gazebo::event::Events’
/home/orbit/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/src/gazebo_ros_api_plugin.cpp: In member function ‘virtual void gazebo::GazeboRosApiPlugin::Load(int, char**)’:
/home/orbit/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/src/gazebo_ros_api_plugin.cpp:111:19: error: ‘ConnectSigInt’ is not a member of ‘gazebo::event::Events’
Linking CXX shared library /home/orbit/catkin_ws/devel/lib/
[ 96%] Built target gazebo_ros_paths_plugin
[ 96%] Built target dummy_app
Scanning dependencies of target effort_controllers
[ 96%] Building CXX object ros_controllers/effort_controllers/CMakeFiles/effort_controllers.dir/src/joint_effort_controller.cpp.o
make[2]: *** [gazebo_ros_pkgs/gazebo_ros/CMakeFiles/gazebo_ros_api_plugin.dir/src/gazebo_ros_api_plugin.cpp.o] Error 1
make[1]: *** [gazebo_ros_pkgs/gazebo_ros/CMakeFiles/gazebo_ros_api_plugin.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 97%] Building CXX object ros_controllers/effort_controllers/CMakeFiles/effort_controllers.dir/src/joint_velocity_controller.cpp.o
[ 97%] Building CXX object ros_controllers/effort_controllers/CMakeFiles/effort_controllers.dir/src/joint_position_controller.cpp.o
Linking CXX shared library /home/orbit/catkin_ws/devel/lib/
[ 97%] Built target effort_controllers
make: *** [all] Error 2
Invoking "make" failed

Best regards,


edit retag flag offensive close merge delete


The link is protected.

nkoenig gravatar imagenkoenig ( 2013-07-01 17:42:52 -0500 )edit

p.s. try for posting code snippets, its better than google docs :)

davetcoleman gravatar imagedavetcoleman ( 2013-07-02 10:45:38 -0500 )edit

4 Answers

Sort by » oldest newest most voted

answered 2013-07-12 18:37:16 -0500

davetcoleman gravatar image

A lot has changed the past week in how Gazebo and gazeborospkgs is installed (SDF has been split into a stand-alone debian).

I encourage you to re-read and redo the instructions on the installation, close this ticket and create a new one if you continue to have issues.

edit flag offensive delete link more

answered 2018-11-29 08:47:55 -0500

Anshul gravatar image

I faced the similar problem with

Blockquote/usr/include/gazebo-1.9/gazebo/physics/State.hh:26:22: fatal error: sdf/sdf.hh: No such file or directory

Instead of changing CMakeCache.txt file I deleted build folder in my catkin workspace and did catkin_make for the fresh installation solved my problem.

edit flag offensive delete link more


This also solved my problem.

I can't upvote (not enough karma it seems...)

wonwon0 gravatar imagewonwon0 ( 2020-10-07 12:46:04 -0500 )edit

answered 2013-07-11 19:36:24 -0500

Shehzi gravatar image

updated 2013-07-11 19:43:17 -0500

Found one solution (not the best way, but it worked for me)
While installing gazebo_ros_pkgs on groovy (any distro that is non-hydro) if an error of the following form comes up during catkin_make :

/usr/include/gazebo-1.9/gazebo/physics/State.hh:26:22: fatal error: sdf/sdf.hh: No such file or directory
Note: the sdf/sdf.hh part may come up more than once.

Let the catkin_make fail, then navigate to


You will find a file CMakeCache.txt open it in any editor and then use search to find all instances of

-I/usr/include/sdf-1.4 and /usr/include/sdf-1.4 in the file.

To these add(do not replace) another command that will include ;/usr/include/sdf-1.4/sdf (note the extra /sdf) so that it should look like

GAZEBO_STATIC_INCLUDE_DIRS:INTERNAL=/usr/include/gazebo-1.9;/usr/include/gazebo-1.9/gazebo;/usr/include/sdf-1.4;/usr/include/sdf-1.4/sdf and


Do this for all instances.

Now go back to ~/catkin_ws and run catkin_make, it should build without errors.

edit flag offensive delete link more


Hi, Shehzi, for me not worked this process. Please post your CMakeCache.txt file. Use ( for add the code here. Thanks a lot.

EduardoMaciel gravatar imageEduardoMaciel ( 2013-07-12 06:22:37 -0500 )edit

Hi EduardoMaciel, install the gazebo prerelease from here you can use sudo-apt get for that now. I will post my CMakeCache.txt file in a few hours, sorry it is on my lab computer.

Shehzi gravatar imageShehzi ( 2013-07-12 10:12:24 -0500 )edit

Hi Shehzi, Thanks a lot.

EduardoMaciel gravatar imageEduardoMaciel ( 2013-07-12 10:37:47 -0500 )edit

Hi EduardoMachiel, here is my CMakeCache.txt - The home/user/catkin_ws/ path will be different in my CmakeCache, make sure those are changed. Let me know what errors you face and I'll try to help as much as I can. Hope we can resolve it by today.

Shehzi gravatar imageShehzi ( 2013-07-12 14:09:53 -0500 )edit

answered 2013-07-01 18:09:09 -0500

nkoenig gravatar image

I believe you need to build Gazebo from source using the default branch.

edit flag offensive delete link more


This is correct, there is a new event we added in Gazebo 1.9 (the default branch)

davetcoleman gravatar imagedavetcoleman ( 2013-07-01 18:50:52 -0500 )edit

Are you sure got all of these? ```sudo apt-get install build-essential libtinyxml-dev libtbb-dev libxml2-dev libqt4-dev pkg-config libprotoc-dev libfreeimage-dev sudo apt-get install libprotobuf-dev protobuf-compiler libboost-all-dev freeglut3-dev cmake libogre-dev libtar-dev sudo apt-get install libcurl4-openssl-dev libcegui-mk2-dev

davetcoleman gravatar imagedavetcoleman ( 2013-07-02 10:44:16 -0500 )edit

Gazebo installed using the source code, I used the following link: and worked. But the package gazeborospkgs is not worked. Erro:

EduardoMaciel gravatar imageEduardoMaciel ( 2013-07-02 14:20:17 -0500 )edit

I think the above issue gazebo/sensors/DepthCameraSensor.hh: No such file or directory is still a Gazebo install issue - try downloading using hg clone, not a zip file? I'm not sure.

davetcoleman gravatar imagedavetcoleman ( 2013-07-02 16:32:54 -0500 )edit

Hello, coleman and nkoenig, Your tip worked, I managed compile the 'Gazebo' and 'gazeborospkg'. Many thanks!

EduardoMaciel gravatar imageEduardoMaciel ( 2013-07-02 20:12:06 -0500 )edit

I am having a similar error with DepthCameraSensor.hh ( ) when I run catkin make for the gazebo_ros_packages. I had installed Gazebo from the mercurial repository and that runs. Thanks for any assistance.

FiliusFortunae gravatar imageFiliusFortunae ( 2013-07-06 01:17:29 -0500 )edit

Hi FiliusFortunae, you must remove your installation (Gazebo and ROS) and reinstall the (Gazebo from source and ros-groovy-ros-base) and recreate the ambience of ROS (~ / catkinws). You must follow the instructions of the links: Don't forget to install the dependencies, which are described in the link "Compile Instructions".

EduardoMaciel gravatar imageEduardoMaciel ( 2013-07-06 08:07:14 -0500 )edit

I tried this, however when I tried only base it gave me this error ( ) so I installed ros-groovy-desktop (which doesn't include gazebo so I thought would work) however I got the same .hh errors again, I also posted a question:

FiliusFortunae gravatar imageFiliusFortunae ( 2013-07-07 01:07:39 -0500 )edit

You must install the dependencies to build the package, for example, ros-groovy-trajectory-msgs, ros-groovy-angles, ros-tf-groovy, groovy-geometry-msgs ros-groovy-and-actionlib-msgs. After installing these dependencies try again.

EduardoMaciel gravatar imageEduardoMaciel ( 2013-07-07 10:37:53 -0500 )edit
Login/Signup to Answer

Question Tools


Asked: 2013-07-01 17:40:06 -0500

Seen: 7,011 times

Last updated: Jul 12 '13