gazebo ros Packages - fatal error: gazebo/sensors/DepthCameraSensor.hh: No such file or directory [closed]

asked 2013-07-07 01:03:37 -0500

FiliusFortunae gravatar image

Running kubuntu 12.04 trying to install gazebo ros Packages with groovy

When I run catkin_make I get for :

[ 53%] Generating Lisp code from gazebo_msgs/GetLinkState.srv
[ 54%] Generating C++ code from gazebo_msgs/GetPhysicsProperties.srv
[ 54%] Building CXX object gazebo_ros_pkgs/gazebo_plugins/CMakeFiles/MultiCameraPlugin.dir/src/MultiCameraPlugin.cpp.o
/home/alex/rcatkin_ws/src/gazebo_ros_pkgs/gazebo_plugins/src/MultiCameraPlugin.cpp:17:47: fatal error: gazebo/sensors/DepthCameraSensor.hh: No such file or directory
compilation terminated.
make[2]: *** [gazebo_ros_pkgs/gazebo_plugins/CMakeFiles/MultiCameraPlugin.dir/src/MultiCameraPlugin.cpp.o] Error 1
make[1]: *** [gazebo_ros_pkgs/gazebo_plugins/CMakeFiles/MultiCameraPlugin.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 54%] [ 55%] Generating Lisp code from gazebo_msgs/GetPhysicsProperties.srv
Generating Python from MSG gazebo_msgs/ODEPhysics
[ 55%] Generating Python from MSG gazebo_msgs/WorldState
[ 55%] [ 56%] Generating C++ code from gazebo_msgs/SetJointProperties.srv

Similar to However, his solution didn't work for me.

I uninstalled ros-groovy-desktop-full and uninstalled gazebo

Then I installed ros-groovy-desktop (having tried ros-groovy-base and gotten missing dependencies)

Downloaded the mercurial at and installed that as directed and it runs and allows putting models in it.

Finally I cloned: gazeborospkgs roscontrol.git roscontrollers.git controltoolbox.git realtimetools.git into my catkin workspace

When I run:

rosdep install --from-paths src --ignore-src --rosdistro groovy -y

I get: ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies:

gazebo_plugins: Cannot locate rosdep definition for [gazebo]
gazebo_ros: Cannot locate rosdep definition for [gazebo]

Finally env might be relevant so:

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by nkoenig
close date 2020-12-18 12:55:01.382976


I'm having the exact same problem. As far as I can tell, gazebo_ros needs to know something about the gazebo installation in order to build, but there is no way to specify this since we built gazebo from source outside of ROS/catkin, etc.

Robert Brockman gravatar imageRobert Brockman ( 2013-07-08 12:37:50 -0500 )edit

I've managed to get beyond these errors by compiling and installing gazebo to a subdirectory of my home directory rather than the default system directory. I still get the "Cannot locate rosdep definition for [gazebo]" error but catkinmake works for gazeboros, I can start gazebo from rosrun, and the correct topics and services appear. Having the correct PKGCONFIGPATH, PATH, and LDLIBRARYPATH set in .bashrc seems to be necessary for ros to find gazebo properly.

Robert Brockman gravatar imageRobert Brockman ( 2013-07-08 14:12:43 -0500 )edit

Hi Robert Brockerman, during the catkin_make did you add -DCMAKE_INSTALL_PREFIX=~/some/home/folder? After that what did you add in the PKG_CONFIG_PATH, PATH and LD_LIBRARY_PATH? It would really help if you can post your installation steps as an answer. Thank you!

Shehzi gravatar imageShehzi ( 2013-07-10 21:31:43 -0500 )edit

Found a solution for this problem. My case was that the required sdf header files were inside /user/include/sdf-1.4/ rather than /user/include/sdf/ Just changed the directory name and catkin_make worked successfully (rosdep still cannot locate dependencies but rosrun now launch gazebo with no problems)

m.guedes gravatar imagem.guedes ( 2013-07-11 05:41:09 -0500 )edit

Hi Filius, we're almost done switching over to a Gazebo standalone debian install for gazebo_ros_pkgs. The last issues should be resolved today but I apologize for your installation woes. I'm not sure what the status of your situation is today, but for your initial problem of gazebo_plugins: Cannot locate rosdep definition for [gazebo] did you try rosdep update?

davetcoleman gravatar imagedavetcoleman ( 2013-07-11 10:13:56 -0500 )edit

Hi m.guedes, where did you make that change? I have the same issue with sdf headers not loading.

Shehzi gravatar imageShehzi ( 2013-07-11 15:57:45 -0500 )edit