Gazebo | Ignition | Community
Ask Your Question

Install gazebo-1.9 stand-alone with ros-groovy on Ubuntu12.04

asked 2013-07-20 07:28:58 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I intalled ros-groovy before, then installed gazebo-1.9.5 according to gazeborospkgs tutorial. But when I tried to execute command

rosrun gazebo_ros gazebo


rosrun gazebo_ros-1.9 gazebo

the result is

[rospack] Error: stack/package gazebo not found


[rospack] Error: stack/package gazebo-1.9 not found

roscore and gazebo-1.9 worked well when ran them one by one. So please can someone help me find out what's the problem and where is wrong? Thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-07-21 13:39:02 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

This looks like gazebo_ros is not s is not in your ROS_PACKAGE_PATH or not even installed to verify that it is try this:


and see if you can find the path to the gazebo_ros folder. As suggested by your link, if you are on groovy you need to install the gazebo_ros package from source, which is also described in the link you shared, try the steps in there again and let me know if that worked.


EDIT: I just checked the installation guide for groovy and it seems to me that in the instructions it never actually switches to the groovy-devel branch but would only rename the ros_gazebo_pkgs folder to groovy-devel, so use the this command instead:

git clone -b groovy-devel

(@OSRF, you could maybe update this in the wiki, if I'm not telling any wrong stuff here ;), I am still on my roadtrip and wasn't following the latest developments)

edit flag offensive delete link more


it is the same problem for hydro (although it is the master branch) git clone <a href=""></a> hydro-devel

evilBiber gravatar imageevilBiber ( 2013-07-22 01:05:14 -0500 )edit

Hey guys thanks for catching that git syntax error. I just fixed it for both the groovy and hydro instructions.

scpeters gravatar imagescpeters ( 2013-07-22 01:37:07 -0500 )edit

Thanks for your reply. Sorry to give you feedback so late. I have reinstalled gazebo_ros from source just as described in the link. But there is still no gazebo_ros folder in the path returned by "echo $ROS_PACKAGE_ROS" which is "/opt/ros/groovy/share:/opt/ros/groovy/stack" on my machine. But I can find folder "gazebo_ros" in the path "catkin_ws/build/gazebo_ros_pkgs", which "catkin_ws" is my workspace folder for ros. I suspect whether I need to add a ROS_PACKAGE_PATH manully.

GumpFang gravatar imageGumpFang ( 2013-07-24 07:39:49 -0500 )edit

BTW your suggestion about git commad works well. I am going to update wiki for it. Thank you

GumpFang gravatar imageGumpFang ( 2013-07-24 07:40:29 -0500 )edit

Issue is solved. It's my mistake. I did not run commad ""echo "source ~/catkin_ws/devel/setup.bash" >> ~/.bashrc"". Sorry for stupid mistake!

GumpFang gravatar imageGumpFang ( 2013-07-25 02:21:05 -0500 )edit

Question Tools


Asked: 2013-07-20 07:28:58 -0500

Seen: 773 times

Last updated: Jul 23 '13