Gazebo | Ignition | Community
Ask Your Question

Model Plugin does not load

asked 2013-07-22 05:13:15 -0500

Chris gravatar image

updated 2013-07-22 05:15:54 -0500

Hey guys,

I am trying to do the following:

run a world with a world plugin -> world plugin creates a model (also with plugin). If I create a sensor with a sensor plugin (dynamically with the world plugin) then the sensor plugin is loaded. The model plugin is not...

I tried multiple versions of gazebo (1.4, 1.6, 1.9). Can you give me a hint?

Here are some code snippets: pastebin

edit retag flag offensive close merge delete


Does it give any hint why? error / warning msg? I used to do this as well and I think it worked.

AndreiHaidu gravatar imageAndreiHaidu ( 2013-07-22 09:16:23 -0500 )edit

First very embarrassing error: I forgot to set the plugin path for the model plugin lib... but this is not the solution.... I will upload some more code and the output (there are no error / warning msg -> its just not loaded)

Chris gravatar imageChris ( 2013-07-22 09:48:10 -0500 )edit

Second error: after the _parent->InsertModelSDF(sphereSDF); in the load method of the world-plugin there was a " node->WaitForConnection();" that waited for a message from the model plugin.... very stupid errors... sorry

Chris gravatar imageChris ( 2013-07-22 10:00:15 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-07-23 19:25:55 -0500

gerkey gravatar image

Looks like @Chris answered his own question in the comments.

edit flag offensive delete link more


Sorry, I don't know how to close a thread....

Chris gravatar imageChris ( 2013-07-24 04:27:47 -0500 )edit

Question Tools


Asked: 2013-07-22 05:13:15 -0500

Seen: 1,382 times

Last updated: Jul 23 '13