Gazebo | Ignition | Community
Ask Your Question

Loading ros_control_gazebo_plugin - Gazebo version 1.9.5

asked 2013-07-22 17:05:04 -0500

EduardoMaciel gravatar image

updated 2013-07-23 17:06:38 -0500

gerkey gravatar image

I have a problem with use the ros_control: No type element found for transmission. See my urdf. For get control functional what I need?

I am using this tutorial, as well as this one.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2013-07-23 20:17:07 -0500

davetcoleman gravatar image

updated 2013-07-24 12:08:36 -0500

Hi Eduardo,

I'm afraid you tried to follow the ros_control tutorial that was not ready to be used yet (as noted at top of page). There have been lots of changes with ros_control since I made that initial draft. I just over-hauled the tutorial and now I'd say it is much closer to being production ready (90%).

In particular, the format of transmissions that you have attempted to use has changed, be sure to update your URDF transmissions.

edit flag offensive delete link more


Very good Dave, your tip worked, but I'm still having a problem, [WARN] [WallTime: 1374687405.894700] [48.796000] Controller Spawner couldn't reach controller_manager to load controllers. My yaml:( and my launch: (

EduardoMaciel gravatar imageEduardoMaciel ( 2013-07-24 12:49:09 -0500 )edit

Same here seems to hang on load controller

Cdrwolfe gravatar imageCdrwolfe ( 2013-08-01 11:39:38 -0500 )edit

I think this is a namespace error... you might could try to change your namespace to ns="/" This worked for me...

evilBiber gravatar imageevilBiber ( 2013-08-14 04:46:04 -0500 )edit
Login/Signup to Answer

Question Tools


Asked: 2013-07-22 17:05:04 -0500

Seen: 1,130 times

Last updated: Jul 24 '13