Gazebo | Ignition | Community
Ask Your Question
1

How to update screen after SetWorldPose in Gazebo v1.8.6

asked 2013-07-23 17:18:01 -0500

Daehyung Park gravatar image

updated 2013-07-23 17:27:59 -0500

I am working on Gazebo v1.8.6 with ROS-Fuerte and PR2.

While I am running my robot, I manipulate some objects using 'gazebo::physics::Entity::SetWorldPose.'

My problem is the following; non-static objects are visually updated correctly after its' position manipulation. However, static objects are not visually updated (its' actual position is changed and there is contact on expected location.)

I can see this kind of situation 9 out of 10 simulations.

Is there any way to force to update screen except 'ConnectWorldUpdateBegin'?

Thanks

edit retag flag offensive close merge delete

Comments

it may be related to this issue in gazebo. I've seen it before too, and happens to static models

iche033 gravatar imageiche033 ( 2013-07-23 17:33:28 -0500 )edit

I am not sure whether it is same or not. But, it looks very similar. I have used Gazebo v1.4.6 and seen this problem. It happens randomly but so much frequently.

Daehyung Park gravatar imageDaehyung Park ( 2013-07-24 09:34:35 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-12-18 12:49:04 -0500

nkoenig gravatar image

I'll mark this question as closed since more recent Gazebo version has this fixed.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2013-07-23 17:18:01 -0500

Seen: 791 times

Last updated: Dec 18 '20