Gazebo | Ignition | Community
Ask Your Question

problem with gazebo 1.9.0 [closed]

asked 2013-07-26 10:29:49 -0600

Vahid gravatar image

Hello Dear All,

I've used standalone gazebo (1.8.6) without any problems and today i update it to (1.9.0) and now when i run my code i got this error:

/home/vahid/My_WorkSpace/Project_Code_5_Qt4/CommonHeaders.hh:2: error: gazebo/transport/transport.hh: No such file or directory

also i add gazebo to cmake of my project in this way:


  pkg_check_modules(GAZEBO gazebo)


also i call headers file of gazebo in this way:

/////////////////////////////////////////////////// Gazebo Headers
#include "gazebo/transport/transport.hh"
#include "gazebo/msgs/msgs.hh"
#include "gazebo/gazebo.hh"
#include "math/gzmath.hh"
#include "gazebo/common/Image.hh"

as i said in gazebo 1.8.6, i don't have any problem and this problem is after updating gazebo to 1.9.0. by the way when i add gazebo-1.9 to address of headers file (#include "gazebo-1.9/gazebo/transport/transport.hh"), my problem is solved but i should add gazebo-1.9 to all headers! any one know what is my fault or what should i do?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by nkoenig
close date 2013-07-30 10:36:41.541285


my problem is solved, i reinstall gazebo and qt!!!

Vahid gravatar imageVahid ( 2013-07-28 06:03:07 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-07-26 10:35:40 -0600

nkoenig gravatar image

You can check that pkg-config returns correct values using:

  pkg-config --cflags gazebo

The output should be something like:

  -I/home/nkoenig/local/include/gazebo-1.9 -I/home/nkoenig/local/include/gazebo-1.9/gazebo -I/home/nkoenig/local/include/sdformat-1.4
edit flag offensive delete link more


Dear nkoeing, when i run above command, the output is( -I/usr/include/gazebo-1.9 -I/usr/include/gazebo-1.9/gazebo -I/usr/include/sdformat-1.4), it's same to you, so what is my fault?

Vahid gravatar imageVahid ( 2013-07-26 10:38:33 -0600 )edit

That's the same as me. Can you check to make sure that /usr/include/gazebo-1.9/gazebo/transport/transport.hh exists?

nkoenig gravatar imagenkoenig ( 2013-07-26 18:28:51 -0600 )edit

yes, i checked it and it's available, also when i copied the gazebo folder from inside of gazebo-1.9 to /usr/include, this error disappear! but i got finding library error!

Vahid gravatar imageVahid ( 2013-07-26 20:12:46 -0600 )edit

You should never manually copy something into an install path, it'll almost always lead to errors. So it sounds like you are compiling from source. Check to make sure that no errors are generated, and that you are running "sudo make install"

nkoenig gravatar imagenkoenig ( 2013-07-30 10:26:13 -0600 )edit

I would also suggest using the binary debian.

nkoenig gravatar imagenkoenig ( 2013-07-30 10:26:57 -0600 )edit

Thank you dear nkoenig, i reinstall again gazebo using the binary debian and my problem is solved.

Vahid gravatar imageVahid ( 2013-07-30 10:30:08 -0600 )edit

answered 2013-07-26 11:06:21 -0600

ynevatia gravatar image

Hi Vahid

As you include path (-I/usr/include/gazebo-1.9/gazebo) includes the gazebo folder , your includes should be not include gazebo but should follow the format

#include "transport/transport.hh"
edit flag offensive delete link more


Dear ynevatia, i test your suggestion, but i got past error again!

Vahid gravatar imageVahid ( 2013-07-26 12:36:02 -0600 )edit

Can you check the contents of the folder /usr/include/gazebo-1.9/gazebo?

ynevatia gravatar imageynevatia ( 2013-07-26 15:04:42 -0600 )edit

Dear ynevatoa, yes i checked it all headers are available on it.

Vahid gravatar imageVahid ( 2013-07-26 20:15:46 -0600 )edit

Question Tools


Asked: 2013-07-26 10:29:49 -0600

Seen: 2,344 times

Last updated: Jul 26 '13