Gazebo | Ignition | Community
Ask Your Question

problem with finding library in gazebo 1.9.0 [closed]

asked 2013-07-26 12:56:10 -0500

Vahid gravatar image

Hello Dear All,

I have a problem after updating gazebo (1.8.6) to (1.9.0), that i explain in this question, by the way i can't solve it and i add gazebo-1.9 to all headers, now when i run my code i got this error:

[ 75%] Built target Manage
[100%] Building CXX object CMakeFiles/main.dir/
Linking CXX executable main
/usr/bin/ld: cannot find -lgazebo_sdf_interface
collect2: ld returned 1 exit status
make[2]: *** [main] Error 1
make[1]: *** [CMakeFiles/main.dir/all] Error 2
make: *** [all] Error 2
22:19:51: The process "/usr/bin/make" exited with code 2.
Error while building project Project (target: Desktop)
When executing build step 'Make'

i searched for libgazebosdfinterface, but i can't find it, any one know what is my fault?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by nkoenig
close date 2013-07-30 10:37:53.546365



my problem is solved, i reinstall gazebo and qt!

Vahid gravatar imageVahid ( 2013-07-28 06:05:38 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-07-26 15:19:24 -0500

ynevatia gravatar image

From Version 1.9.0 SDF is now a separate library and cannot be linked through Gazebo.

You can find an overview at

edit flag offensive delete link more

answered 2013-07-26 18:31:36 -0500

nkoenig gravatar image

Are you compiles gazebo from source, or using the debians?

Also, please post the output of:

pkg-config --libs gazebo
edit flag offensive delete link more


Dear nkoenig, in first i installed gazebo using the debians ( i think 1.6.X ) and i get updated package with automatic update of software center.

Vahid gravatar imageVahid ( 2013-07-26 20:06:53 -0500 )edit

the output of above command is : -Wl,-rpath,/usr/lib,-rpath,/usr/lib/gazebo-1.9/plugins -L/usr/lib/gazebo-1.9/plugins -lgazebo_transport -lgazebo_physics -lgazebo_sensors -lgazebo_rendering -lsdformat -lgazebo_msgs -lgazebo_math -lgazebo_common -lgazebo

Vahid gravatar imageVahid ( 2013-07-26 20:07:32 -0500 )edit

Hi Vahid, try -lsdformat instead of -lgazebo_sdf_interface, maybe that will help

ynevatia gravatar imageynevatia ( 2013-07-27 02:44:38 -0500 )edit

Question Tools


Asked: 2013-07-26 12:56:10 -0500

Seen: 305 times

Last updated: Jul 26 '13