Gazebo | Ignition | Community
Ask Your Question

Installing Gazebo 1.9 and gazebo_ros_pkgs from source (missing package cmake_modules).

asked 2013-08-01 10:29:56 -0500

Christoph gravatar image

updated 2013-08-01 10:43:42 -0500

Hi all,

after having some problems with my already working gazebo ros plugins and the new gazebo_ros_pkgs (see my question 3557) I tried to reinstall all components (ros groovy, Gazebo and gazebo_ros_pkgs - all Gazebo parts from source) following the tutorials and At the point where I had to build the gazebo_ros_pkgs (with catkin_make) I got the following error message:

CMake Error at /opt/ros/groovy/share/catkin/cmake/catkinConfig.cmake:72 (find_package):
  Could not find a configuration file for package cmake_modules.

  Set cmake_modules_DIR to the directory containing a CMake configuration
  file for cmake_modules.  The file will have one of the following names:


Call Stack (most recent call first):
  ros_control/transmission_interface/CMakeLists.txt:31 (find_package)

CMake Error at ros_control/transmission_interface/CMakeLists.txt:37 (find_package):
  Could not find module FindTinyXML.cmake or a configuration file for package

  Adjust CMAKE_MODULE_PATH to find FindTinyXML.cmake or set TinyXML_DIR to
  the directory containing a CMake configuration file for TinyXML.  The file
  will have one of the following names:


CMake Error at /opt/ros/groovy/share/catkin/cmake/catkin_package.cmake:156 (message):
  catkin_package() DEPENDS on 'TinyXML' which must be find_package()-ed
  before.  If it is a catkin package it can be declared as CATKIN_DEPENDS
  instead without find_package()-ing it.
Call Stack (most recent call first):
  /opt/ros/groovy/share/catkin/cmake/catkin_package.cmake:98 (_catkin_package)
  ros_control/transmission_interface/CMakeLists.txt:40 (catkin_package)

-- Configuring incomplete, errors occurred!
Invoking "cmake" failed

It seemed to me, that I got this error message before as I tried another way of reinstalling gazebo with the pre-compiled binaries. And I am not sure if I am the only one with this error.

I'll directly post my solution.

Cheers, Christoph

edit retag flag offensive close merge delete


Did you install all components from the source or only gazeb_ros_pkgs?

Arn-O gravatar imageArn-O ( 2013-08-01 10:37:37 -0500 )edit

@_ArnO_ : I updated my question. This time I installed all components from source. I tried mixed versions like described in the tutorials before. With the same or different errors.

Christoph gravatar imageChristoph ( 2013-08-01 10:46:23 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-08-01 10:42:33 -0500

Christoph gravatar image

What I did:

cloning the missing package into my catkin_workspace/src folder like

git clone

Then run catkin_make again. This time there weren't errors anymore.

After adding the missing package the topics and services listed in the tutorials are all there and my old gazebo ros plugins seem to work again.

As said before, I am not sure if I am the only one who got that error or if it is a common error and that information maybe belongs to the wiki.

edit flag offensive delete link more


I also got this error and this also fixed it for me. Thanks so much.

mwd gravatar imagemwd ( 2013-08-01 11:33:11 -0500 )edit

This worked for me as well

Cdrwolfe gravatar imageCdrwolfe ( 2013-08-01 11:38:20 -0500 )edit

My apologies on this issue, we added the cmake_modules dependency because we thought it was already released into Groovy, but actually it is waiting for the next update of debian into Groovy from the build farm - this should fix itself in the next couple days but you hit the error now. I've temporarily updated the documentation.

davetcoleman gravatar imagedavetcoleman ( 2013-08-01 12:58:04 -0500 )edit

Thanks, it also worked for me.

rguzman gravatar imagerguzman ( 2013-08-07 12:27:55 -0500 )edit

Problem still exist when trying to install ros_control hydro from source, though the above answer still solves the problem

Cdrwolfe gravatar imageCdrwolfe ( 2013-09-02 16:11:04 -0500 )edit

Thanks. It also worked for me.

atp gravatar imageatp ( 2014-01-22 17:10:00 -0500 )edit

answered 2014-02-15 16:25:09 -0500

duffany1 gravatar image

updated 2014-02-15 16:25:55 -0500

Change to your workspace directory and run the command

rosdep install --from-paths . --ignore-src --rosdistro groovy -y
edit flag offensive delete link more

Question Tools


Asked: 2013-08-01 10:29:56 -0500

Seen: 5,613 times

Last updated: Feb 15 '14