Gazebo | Ignition | Community
Ask Your Question

Gazebo_Ros_Pkgs for hydro error with gazebo 1.9.0 [closed]

asked 2013-08-09 13:46:51 -0500

aqiruse gravatar image

I am following the directions at:

I built the ros hydro package and integrated it with gazebo 1.9.0 however when i run the commands in separate terminal widows:

roscore &
rosrun gazebo_ros gazebo

I recieve the following error at the command line and no gazebo window:

Gazebo multi-robot simulator, version 1.9.0
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.

Msg Waiting for master.Warning [] No <sdf> element in file[/home/dev/ros_catkin_ws/install_isolated/lib/]
Error [] Unable to load file[/home/dev/ros_catkin_ws/install_isolated/lib/].
Warning [] No <sdf> element in file[urdf file]
Error [] parse as old deprecated model file failed.
Error [] Unable to read sdf file[/home/dev/ros_catkin_ws/install_isolated/lib/]
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::lock_error> >'
  what():  boost::lock_error
Error [] Failed to connect to master in 30 seconds.
/home/dev/code/catkin_workspace/src/gazebo_ros_pkgs/gazebo_ros/scripts/gazebo: 25: kill: invalid signal number or name: SIGINT

Any ideas on how to solve this issue? gazebo will run fine alone if just typing gazebo in the terminal. However as run in the above, it produces an error.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by aqiruse
close date 2013-08-12 12:18:19.985317


Which way did you follow? I had similar issues when installing from the debs (I'm only talking about the gazebo_ros_pkgs package).

Arn-O gravatar imageArn-O ( 2013-08-09 16:25:56 -0500 )edit

I was tired when I installed this, but I think my mistake was following all the directions. First I installed Gazebo on Ubuntu 13.04. I already had ROS Groovy Installed. I checked to make sure Gazebo worked and it did. I think I may have forgotten to uninstall the groovy packages to switch to hydro. Then I believe I may have installed the debs, and then done a source code build of hydro and and gazeborospkgs. Then I tried to run the above and received an error. I will try to uninstall & retry.

aqiruse gravatar imageaqiruse ( 2013-08-09 23:21:52 -0500 )edit

I finally have it working. I installed from source, and had the same error as before. It turns out, something was wrong with the package paths. I installed the prerelease of gazebo. Then I deleted the source folders or hydro and gazebo. I deleted the .gazebo and .ros folders from user directory. Then I installed ros-hydro- which uninstalled gazebo-prerelease. Then I edited the .bashrc paths removing the unnecessary ones. Finally I reinstalled the ros-hydro-rosbash, rosbuild, etc. It works now.

aqiruse gravatar imageaqiruse ( 2013-08-11 23:34:59 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-08-12 11:44:39 -0500

Arn-O gravatar image

OK, so, this question should be closed!

edit flag offensive delete link more

Question Tools


Asked: 2013-08-09 13:46:51 -0500

Seen: 1,769 times

Last updated: Aug 12 '13