Gazebo | Ignition | Community
Ask Your Question

gazebo crashes immediately using roslaunch after installing gazebo ros packages

asked 2013-08-13 03:03:00 -0500

Zahra gravatar image

updated 2016-07-23 17:46:34 -0500

yah130s gravatar image


after installing everything properly I am following the tutorials to test the tools (using groovy, gazebo 1.9 and gazebo_ros_pkgs). I have a problem using roslaunch to start gazebo following this tutorial

when I want to start with command roslaunch gazebo_ros willowgarage_world.launch gazebo crashes after one sec and I get this error:

[gazebo_gui-3] process has died [pid 15649, exit code 139, cmd /home/usr/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/scripts/gzclient __name:=gazebo_gui __log:=/home/shahed/.ros/log/8981441a-03ea-11e3-8d2b-0017c4a8146b/gazebo_gui-3.log].
log file: /home/usr/.ros/log/8981441a-03ea-11e3-8d2b-0017c4a8146b/gazebo_gui-3*.log

this problem happens with all world files( mud_world.launch, shapes_world.launch, rubble_world.launch), except the empty and willowgarage_world, both of them can be started using roslaunch tool but not always from the first attempt. Mostly from the second try.

I also followed “Creating a Custom World File” in the same tutorial and still the same problem occurred.

Any help plz!

Thanks in advance.

edit retag flag offensive close merge delete

6 Answers

Sort by » oldest newest most voted

answered 2013-08-23 02:32:46 -0500

Zahra gravatar image


I followed this approach :

first, start with . ~/catkin_ws/devel/setup.bash . Then killall gzserver even if there is no process running and then roslaunch package[name] launch file[name].

Most of the time it works and if it doesnt just wait about 3 minutes before starting again , I still dont know why this is happening but after doing the above steps I am able to run my simulation with roslaunch from first or second attempt.

Hope it is helpful!

edit flag offensive delete link more


Hi, killall gzserver worked for me. Thank you!

Shehzi gravatar imageShehzi ( 2013-09-22 11:24:22 -0500 )edit

Great, if the problem is constant you can try this way, it worked better for me.

Zahra gravatar imageZahra ( 2013-09-22 13:20:25 -0500 )edit

I was having a similar problem, but with "roslaunch turtlebot3_gazebo turtlebot3_empty_world.launch". Your solution worked for me! Thanks, so much!

mkelly66 gravatar imagemkelly66 ( 2019-07-24 03:59:34 -0500 )edit

This did not work for me :(

desmond13 gravatar imagedesmond13 ( 2020-11-25 10:14:41 -0500 )edit

answered 2016-02-16 11:21:33 -0500

pcdangio gravatar image

The problem is that roslaunch secretly adds two hidden arguments when starting up a node's executable: _name and _log. If you are calling an executable through roslaunch that is not ROS interoperable, then that executable may fail at startup because it doesn't know how to handle the _name and _log arguments. This is the case here, since roslaunch is actually calling a script file (rungazebo), which is a script that executes the "gazebo" command while passing in all arguments from roslaunch. Gazebo doesn't know how to handle the _name and _log arguments so it dies.

edit flag offensive delete link more


Minor correction; `__name` and `__log`, I guess double underscore instead of single.

yah130s gravatar imageyah130s ( 2016-07-23 17:41:11 -0500 )edit

Your explanation sounds like that Gazebo processes should always die when they are called from `roslaunch`? There are number of successful .launch files out there so I think that's not the case.

yah130s gravatar imageyah130s ( 2016-07-23 17:53:08 -0500 )edit

answered 2017-08-04 12:41:10 -0500

amkros gravatar image

This approach has worked for me after multiple installs and uninstalls finally. If you are using VirtualBox for running ubuntu just disable 3D acceleration from settings for your version. This solved the problem gazebo along with rViz which were crashing (un)expectedly. Although it did make the system slow. You can't have both at once. Hope this helps!!

edit flag offensive delete link more


Thanks. it worked for me

AliZ-ee gravatar imageAliZ-ee ( 2019-07-19 04:27:03 -0500 )edit

answered 2013-08-22 19:40:09 -0500

tania gravatar image

Hey Zahra, even i am facing a similar issue trying to start gazebo using the command:

roslaunch atlasutils vrctask_1.launch . Following error is displayed :

[gazebo-2] process has died [pid 2671, exit code 127, cmd /usr/local/share/drcsim-2.7/ros/atlasutils/scripts/rungazebo -q -r --recordencoding=zlib --recordpath=/tmp/vrctask1 _name:=gazebo _log:=/home/tania/.ros/log/5704913c-0b8c-11e3-ba22-6c8814fca2c8/gazebo-2.log]. log file: /home/tania/.ros/log/5704913c-0b8c-11e3-ba22-6c8814fca2c8/gazebo-2*.log

Can you please tell me how you fixed it?

edit flag offensive delete link more



hey, the error I was getting related to gui and its anser in this question:

Zahra gravatar imageZahra ( 2013-09-22 13:13:22 -0500 )edit

your error [gazebo-2] is related to urdf or sdf file and you need to find out I guess by looking in the log file. I got that kind of errors couple of times and it was related to my sdf file when I spawned it from launch file.

Zahra gravatar imageZahra ( 2013-09-22 13:18:04 -0500 )edit

answered 2020-11-09 20:57:02 -0500

ahmadF gravatar image

hi, I have exactly the same problem but these approaches does not work for me. Do you have any solution plz?

edit flag offensive delete link more

answered 2019-07-24 08:04:44 -0500

uchiha_saail gravatar image

Its because your gazebo server is running at the background. Check by entering top command in terminal you will find there the process running gzserver and gzclient and note down their PID 1st column . You can turn it off by kill -9 PID. PID of gzserver and gzclient. e.g. kill -9 8457. Now try launching gazebo, it will work.

edit flag offensive delete link more


For me there is nothing in top related to gazebo. And I still have the same problem after doing killall gzserver

desmond13 gravatar imagedesmond13 ( 2020-07-08 07:39:55 -0500 )edit
Login/Signup to Answer

Question Tools


Asked: 2013-08-13 03:03:00 -0500

Seen: 55,493 times

Last updated: Aug 04 '17