Gazebo | Ignition | Community
Ask Your Question

gazebo_gui-3 error when starting gazebo with roslaunch

asked 2013-09-02 10:25:05 -0500

Zahra gravatar image

updated 2016-07-23 17:26:56 -0500

yah130s gravatar image


I have this problem that's happening more often the whole last week when starting gazebo using roslaunch, I haven't installed any updates though. Is there any permanent solution for it because it so annoying not to start gazebo right away and it works only after 5 to 6 times attempts

The system: gazebo 1.9.1, groovy, gazebo_ros_package

Segmentation fault (core dumped)
[gazebo_gui-3] process has died [pid 16577, exit code 139, cmd /home/zahraa/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/scripts/gzclient __name:=gazebo_gui __log:=/home/zahraa/.ros/log/4139ed3a-13e2-11e3-9765-6c626d02622d/gazebo_gui-3.log].
log file: /home/zahraa/.ros/log/4139ed3a-13e2-11e3-9765-6c626d02622d/gazebo_gui-3*.log

I tried to find the error by going to 4139ed3a-13e2-11e3-9765-6c626d02622d but this directory doesn't not have gazebo_gui-3*.log file and it has other log files such as spawn_urdf.log and master.log etc..

thanks in advance!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2013-09-04 04:09:59 -0500

Zahra gravatar image

solved by starting gazebo client in another terminal after sourcing . ~/catkin_ws/devel/setup.bash

and rosrun gazebo_ros gzclient

edit flag offensive delete link more


Newie here, could you elaborate in what you needed to do?

Bimblis gravatar imageBimblis ( 2016-08-04 09:50:47 -0500 )edit

This did not work for me :(

desmond13 gravatar imagedesmond13 ( 2020-07-08 07:44:29 -0500 )edit

Anyone has more info on this problem? I have it again now.

desmond13 gravatar imagedesmond13 ( 2020-11-25 02:59:17 -0500 )edit

answered 2016-02-16 11:29:29 -0500

pcdangio gravatar image

updated 2016-07-23 17:57:03 -0500

yah130s gravatar image

The problem is that roslaunch secretly adds two arguments when starting a node's executable: __name and __log. If the node's executable is not ROS interoperable, then the executable may fail because it doesn't know how to handle the __name and __log arguments that were added on by roslaunch. This is the case here, since roslaunch is calling the "gzclient" script, which executes "gzclient" with arguments passed in by roslaunch. gzclient dies because it doesn't know how to handle the __name and __log arguments passed in from roslaunch.

The workaround you found works because it uses rosrun to start the gzclient instead of roslaunch. rosrun doesn't add those pesky "__name" and "__log" parameters.

edit flag offensive delete link more



+1 for raising attention to those 2 options. I still have the same question as the one I made at [this post](

yah130s gravatar imageyah130s ( 2016-07-23 18:05:49 -0500 )edit

Question Tools



Asked: 2013-09-02 10:25:05 -0500

Seen: 34,750 times

Last updated: Jul 23 '16