Gazebo | Ignition | Community
Ask Your Question

turtlebot_gazebo world not loading models

asked 2013-09-19 16:31:01 -0600

nunojpg gravatar image

updated 2014-10-14 18:36:04 -0600

I'm with Ubuntu 13.04 x64 and I have installed:

Package: gazebo
Version: 1.9.1-2~raring
Package: ros-hydro-turtlebot-gazebo
Version: 2.1.0-1raring-20130910-0236-+0000

When I run:

$ gazebo /usr/share/gazebo-1.9/worlds/

It all works fine, the world is loaded and the models are cached at ~/.gazebo/models/

On the other hand if I run:

$ gazebo /opt/ros/hydro/share/turtlebot_gazebo/worlds/

It DOES NOT load any models:

Error [] Unable to download model[model://dumpster/meshes/dumpster.dae]
Error [] File or path does not exist[""]
Error [] No mesh specified
Error [] Unable to download model[model://cube_20k/meshes/cube_20k.stl]
Error [] File or path does not exist[""]
Error [] No mesh specified
Msg Waiting for model database update to complete...
Error [] Unable to download model[model://dumpster/meshes/dumpster.dae]

Gazebo GUI opens, and if I insert the models manually using the GUI library (Dumpster, Cube 20k, etc), they do get cached and next time I run it they load fine.

edit retag flag offensive close merge delete


We had the same issue here in our lab. It can be solved by manually adding those missing models from the online database to the world. The next time Gazebo is started the models are loaded correctly. However, this can't be the right way to do it. We have ticketed that problem here:

bit-pirate gravatar imagebit-pirate ( 2013-09-25 00:24:13 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-10-17 15:51:42 -0600

nkoenig gravatar image

You should see this message on the command line:

Warning [] Getting models from[]. This may take a few seconds.

It may take a minute or so to download the models.

If that doesn't work then you may need Gazebo 2.0. Since you are using ROS hydro, which relies on Gazebo 1.9.2, I would recommend against installing Gazebo 2.0. Instead, you can grab the models manually.

wget .
tar xvf model.tar.gz -C ~/.gazebo/models

Repeat that for cube_20k.

edit flag offensive delete link more

Question Tools


Asked: 2013-09-19 16:31:01 -0600

Seen: 10,726 times

Last updated: Oct 14 '14