Gazebo | Ignition | Community
Ask Your Question

collada files not visualized in Gazebo 1.9

asked 2013-09-25 10:44:49 -0500

Rasmus gravatar image

updated 2013-09-25 10:45:29 -0500

Hi all,

I have a robot using (collada) .dae files for visualization. Before Gazebo 1.9 they worked just fine, but after updating to 1.9 they do not show up anymore. (previously I used the version which came with ROS-fuerte, don't know the actual version number..)

Here are relevant parts of one of the files:

<?xml version="1.0" encoding="utf-8"?>
<COLLADA version="1.4.0" xmlns="">
   <author>Illusoft Collada 1.4.0 plugin for Blender -</author>
   <authoring_tool>Blender v:249 - Illusoft Collada Exporter v:0.3.162</authoring_tool>
  <unit meter="0.01" name="centimeter"/>
  <effect id="black-fx" name="black-fx">
    <technique sid="blender">
       <color>0.00000 0.00000 0.00000 1</color>
       <color>0.43854 0.43854 0.43854 1</color>
       <color>0.43854 0.43854 0.43854 1</color>
       <color>0.25000 0.25000 0.25000 1</color>
  <material id="black" name="black">
   <instance_effect url="#black-fx"/>
  <geometry id="arm0-Geometry" name="arm0-Geometry">
    <source id="arm0-Geometry-Position">
     <float_array count="14850" id="arm0-Geometry-Position-array"> .... </float_array>
      <accessor count="4950" source="#arm0-Geometry-Position-array" stride="3">
       <param type="float" name="X"></param>
       <param type="float" name="Y"></param>
       <param type="float" name="Z"></param>
    <source id="arm0-Geometry-Normals">
     <float_array count="29985" id="arm0-Geometry-Normals-array">.....</float_array>
      <accessor count="9995" source="#arm0-Geometry-Normals-array" stride="3">
       <param type="float" name="X"></param>
       <param type="float" name="Y"></param>
       <param type="float" name="Z"></param>
    <vertices id="arm0-Geometry-Vertex">
     <input semantic="POSITION" source="#arm0-Geometry-Position"/>
    <triangles count="9995" material="black">
     <input offset="0" semantic="VERTEX" source="#arm0-Geometry-Vertex"/>
     <input offset="1" semantic="NORMAL" source="#arm0-Geometry-Normals"/>
     <p> ... </p>
  <visual_scene id="Scene" name="Scene">
   <node layer="L1" id="arm0" name="arm0">
    <translate sid="translate">0.00000 0.00000 0.00000</translate>
    <rotate sid="rotateZ">0 0 1 0.00000</rotate>
    <rotate sid="rotateY">0 1 0 -0.00000</rotate>
    <rotate sid="rotateX">1 0 0 0.00000</rotate>
    <scale sid="scale">1.00000 1.00000 1.00000</scale>
    <instance_geometry url="#arm0-Geometry">
       <instance_material symbol="black" target="#black">
        <bind_vertex_input input_semantic="TEXCOORD" input_set="1" semantic="CHANNEL1"/>
  <instance_visual_scene url="#Scene"/>
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-09-29 10:23:44 -0500

Arn-O gravatar image

Try to modify the unit:

<unit name="meter" meter="1"/>

I had a similar issue one day and that worked for me.

edit flag offensive delete link more


Thanks a lot! It solved the problem. Did the interface between collada files and gazebo change somehow?

Rasmus gravatar imageRasmus ( 2013-09-30 07:09:06 -0500 )edit

I couldn't tell. I had compared a file that was working and another that wasn't. Basic debugging method.

Arn-O gravatar imageArn-O ( 2013-10-01 16:52:03 -0500 )edit

Question Tools


Asked: 2013-09-25 10:44:49 -0500

Seen: 793 times

Last updated: Sep 29 '13