Gazebo | Ignition | Community
Ask Your Question

Gazebo 1.9 failed to load plugin:

asked 2013-09-30 18:00:52 -0500

Mark_GU gravatar image

Hi everyone,

I am using Gazebo 1.9 with ROS groovy. As I am trying the RRBot example(Link here), I kept getting the following error messages when launching gazebo:

Error [Plugin.hh:127] Failed to load plugin cannot open shared object file: No such file or directory
Error [Plugin.hh:127] Failed to load plugin cannot open shared object file: No such file or directory

I am using gazebo_ ros_ pkg within catkin workspace, and the ".so" files are actually located in /home/mark/catkin_ws/devel/lib.
Any comments or suggestions would be appreciated!

edit retag flag offensive close merge delete



I'm working in RRbot but I have problems with the catkin_make in this Tutorial

the problem is when to used:

cd ~/catkin_ws/src/
git clone <a href=""></a>
cd ..
vncntmh gravatar imagevncntmh ( 2013-10-01 07:36:51 -0500 )edit

Get this error:

Traceback (most recent call last):
File "/opt/ros/groovy/bin/catkinmake", line 14, in &lt;module&gt; from catkin.terminalcolor import     disableANSIcolors, fmt
vncntmh gravatar imagevncntmh ( 2013-10-01 07:41:32 -0500 )edit

@vncntmh Not quite familiar with your problem, it looks like something went wrong with your catkin workspace. Does "catkin_make" work before your included the package "gazebo_ ros_ demos"?

Mark_GU gravatar imageMark_GU ( 2013-10-01 11:04:12 -0500 )edit

@Mark_GU, the problem were because I had used ros/fuerte and it change to ros/groovy

A lot of thanks!!

vncntmh gravatar imagevncntmh ( 2013-10-01 18:17:40 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-10-01 03:22:22 -0500


what is in your GAZEBO_PLUGIN_PATH variable (type echo $GAZEBO_PLUGIN_PATH in a terminal)

if it not contains /home/mark/catkin_ws/devel you should append it (type GAZEBO_PLUGIN_PATH=$GAZEBO_PLUGIN_PATH:/home/mark/catkin_ws/devel)

I haven't found this in the tutorial but I think it must be there somewhere ;)

you can find it in the manual Manual plugins

hope this solves your problem

edit flag offensive delete link more


Thank you. I tried the method your suggested. Somehow my GAZEBO_ PLUGIN_ PATH shows nothing by default. So now even if I added "/home/mark/catkin_ws/devel" to it, I still get the error. Thus I was wondering if any other path is needed

Mark_GU gravatar imageMark_GU ( 2013-10-01 10:59:56 -0500 )edit

answered 2013-10-01 08:03:21 -0500

edit flag offensive delete link more


Can you please show me all the paths included in your GAZEBO_ PLUGIN_ PATH? Because my GAZEBO_ PLUGIN_ PATH defaults to nothing. Even when I added the path that includes the .so file, it is still showing the error. Thanks

Mark_GU gravatar imageMark_GU ( 2013-10-01 10:54:49 -0500 )edit


My path is and this's In ~/gazebo/my_plugin/build

Before to get this path I used:

cmake ..;make  //in the folder /build

I used:

cd ~/gazebo/my_plugin/build  //here is

export GAZEBO_PLUGIN_PATH=`pwd`:$GAZEBO_PLUGIN_PATH  //with this instruction I load and it's prepared it for load the simulation

In my case I insert the robot from Gazebo

hope this solves your problem, GoodBye!!

vncntmh gravatar imagevncntmh ( 2013-10-01 16:36:11 -0500 )edit

Question Tools

1 follower


Asked: 2013-09-30 18:00:52 -0500

Seen: 8,987 times

Last updated: Oct 01 '13