Gazebo | Ignition | Community
Ask Your Question

gzclient throws OGRE Exception

asked 2013-10-15 09:23:01 -0500

Schloerri gravatar image

updated 2013-10-15 13:08:36 -0500

I'm running Ubuntu 13.04 64-bit on a machine with an NVIDIA Quadro FX1500 graphics card. I installed gazebo following the instructions in the tutorial. The gzserver starts fine. If I start gzclient using the proprietary nvidia-304 driver it crashes with the following output:

Gazebo multi-robot simulator, version 1.9.1
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.

Msg Waiting for master
Msg Connected to gazebo master @
Msg Publicized address:
Qt has caught an exception thrown from an event handler. Throwing
exceptions from an event handler is not supported in Qt. You must
reimplement QApplication::notify() and catch all exceptions there.

terminate called after throwing an instance of 'Ogre::InvalidParametersException'
  what():  OGRE EXCEPTION(2:InvalidParametersException): All framebuffer formats with this texture internal format unsupported in GLFrameBufferObject::initialise at /build/buildd/ogre-1.7.4+dfsg1/RenderSystems/GL/src/OgreGLFrameBufferObject.cpp (line 276)
Aborted (core dumped)

The guys at this and this link seem to have had a similar problem, but as I'm running 64-bit Ubuntu with the latest driver these solutions don't work for me. When using the open-source driver gzclient starts but the computer is unusably slow.

Any idea on how to fix this?

EDIT: glxinfo runs without an error as far as I can tell and tells me Hardware Rendering is enabled:

direct rendering: Yes
OpenGL renderer string: Quadro FX 1500/PCIe/SSE2
    GL_NV_vertex_program3, GL_NVX_conditional_render, 
    GL_OES_depth_texture, GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,
edit retag flag offensive close merge delete


Can you confirm if this is still present in latests versions of gazebo?

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2013-10-30 09:35:51 -0500 )edit

I have the same problem here on Ubuntu 14.04 (64 bits), NVIDIA Quadro FX 3450 with the latest drivers from I tried the gazebo2 package, building and installing gazebo4 from source, and installing from All approaches yield the same error.

Stéphane Caron gravatar imageStéphane Caron ( 2015-03-10 01:54:38 -0500 )edit

Something interesting in the ~/gazebo/ogre.log ?

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2015-03-25 12:42:26 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2015-01-02 21:57:29 -0500

Innovt gravatar image

Having the same problem with gazebo-4.1.0

edit flag offensive delete link more


Can you paste the output of `glxinfo` on pastebin or a gist?

scpeters gravatar imagescpeters ( 2015-01-05 13:23:08 -0500 )edit

The ~/gazebo/ogre.log could also be useful. I see several ways of trying to solve the problem: update graphic card drivers, update ubuntu or try to build gazebo from source using ogre-1.8.

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2015-01-13 18:12:15 -0500 )edit

Question Tools

1 follower


Asked: 2013-10-15 09:23:01 -0500

Seen: 1,372 times

Last updated: Jan 02 '15