Gazebo | Ignition | Community
Ask Your Question

Cannot see mesh file in Gazebo 1.2.5

asked 2012-12-12 07:42:14 -0500

AndreiHaidu gravatar image


The simulation does not visualize the mesh of a robotic hand model in Gazebo 1.2.5, which under Gazebo 1.0.2 worked fine.

The URI to the .dae file is correct in the sdf (v1.2) file. (I tried it with another .dae file from PR2 and it visualized it).

The difference between the files was that mine had COLLADA version 1.4.0, and PR2 had version 1.4.1. So I imported it in Blender and exported it as version 1.4.1 and it still did not work.

Here is my original .dae file, here it is after converting it in 1.4.1 and this is a PR2 .dae file which works.

Any ideas?

Thanks, Andrei

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2012-12-12 13:09:26 -0500

nkoenig gravatar image

It looks like the collada file has incorrect units. Open up your original dae file, and go to this line:

<unit meter="0.01" .../>

Change to `meter="1.0"'

edit flag offensive delete link more


It worked, thanks a lot.

AndreiHaidu gravatar imageAndreiHaidu ( 2012-12-13 03:40:54 -0500 )edit

Question Tools


Asked: 2012-12-12 07:42:14 -0500

Seen: 559 times

Last updated: Dec 12 '12