Gazebo | Ignition | Community
Ask Your Question
0

Tons of Errors building Gazebo on Ubuntu 13.10

asked 2013-11-05 08:54:29 -0600

aqiruse gravatar image

updated 2013-11-06 06:59:11 -0600

Jose Luis Rivero gravatar image

When I try to build gazebo, and I have been trying for 2 hours now. I receive many errors. I have installed every boost library i can think of, ogre, sdf, etc, etc etc. And it still will not compile. It still tells me I need boost. Boost is already installed. The output of cmake reads:

:~/Code/gazebo_maps/build$ cmake ../
-- Gazebo version 2.0.0
-- Found CPack generators: DEB
-- High memory tests: enabled
-- 

====== Finding 3rd Party Packages ======
-- Operating system is Linux
-- checking for module 'freeimage>='
Must specify package names on the command line
--   package 'freeimage>=' not found
--   freeimage.pc not found, trying freeimage_include_dir and freeimage_library_dir flags.
--   Looking for FreeImage.h - found
--   Looking for libfreeimage - found
-- checking for module 'libprofiler'
--   package 'libprofiler' not found
-- Looking for libprofiler - not found
-- checking for module 'libtcmalloc'
--   package 'libtcmalloc' not found
-- Looking for libtcmalloc - not found
-- Looking for CEGUI, found
-- Looking for CEGUI-OGRE, found
CMake Warning at cmake/SearchForStuff.cmake:130 (find_package):
  By not providing "FindSimbody.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Simbody", but
  CMake did not find one.

  Could not find a package configuration file provided by "Simbody" with any
  of the following names:

    SimbodyConfig.cmake
    simbody-config.cmake

  Add the installation prefix of "Simbody" to CMAKE_PREFIX_PATH or set
  "Simbody_DIR" to a directory containing one of the above files.  If
  "Simbody" provides a separate development package or SDK, be sure it has
  been installed.
Call Stack (most recent call first):
  CMakeLists.txt:149 (include)


--  Simbody not found, for simbody physics engine option, please install libsimbody-dev.
-- Looking for tinyxml.h - found
-- Looking for libtar.h - found
Package OGRE was not found in the pkg-config search path.
Perhaps you should add the directory containing `OGRE.pc'
to the PKG_CONFIG_PATH environment variable
No package 'OGRE' found
CMake Error at cmake/SearchForStuff.cmake:187 (string):
  string sub-command REPLACE requires at least four arguments.
Call Stack (most recent call first):
  CMakeLists.txt:149 (include)


-- checking for module 'OGRE-Overlay'
--   package 'OGRE-Overlay' not found
--  Failed to find OGRE's plugin directory.  The build will succeed, but gazebo will likely fail to run.
-- checking for module 'libswscale'
--   package 'libswscale' not found
--  libswscale not found. Audio-video capabilities will be disabled.
-- checking for module 'libavformat'
--   package 'libavformat' not found
--  libavformat not found. Audio-video capabilities will be disabled.
-- checking for module 'libavcodec'
--   package 'libavcodec' not found
--  libavcodec not found. Audio-video capabilities will be disabled.
-- checking for modules 'playercore>=3.0;playerc++'
--   package 'playercore>=3.0' not found
--   package 'playerc++' not found
--  Player not found, gazebo plugin for player will not be built.
-- checking for module 'gts'
--   package 'gts' not found
--  GNU Triangulation Surface library not found - Gazebo will not have CSG support.
-- Boost version: 1.53.0
CMake Error at /usr/share/cmake-2.8/Modules/FindBoost.cmake:1126 (message):
  Unable to find the requested Boost libraries.

  Boost version: 1.53.0

  Boost include path: /usr/include

  The following Boost libraries could not be found:

      boost_signals
      boost_system
      boost_filesystem
      boost_program_options
      boost_regex
      boost_iostreams

  Some (but not all) of the ...
(more)
edit retag flag offensive close merge delete

Comments

It also can't find ogre. Can you paste the output of the following commands to see which debs you have installed? `dpkg -l | grep libogre` and `dpkg -l | grep libboost`

scpeters gravatar imagescpeters ( 2013-11-05 18:12:25 -0600 )edit

dev@dev-700Z7C:~$ dpkg -l | grep libogre ii libogre-1.7.4:amd64 1.7.4+dfsg1-7 amd64 3D Object-Oriented Graphics Rendering Engine (libraries) ii libogre-1.8.0:amd64 1.8.1+dfsg-0ubuntu1 amd64 3D Object-Oriented Graphics Rendering Engine (libraries) dev@dev-700Z7C:~$ dpkg -l | grep libboost ii libboost-all-dev 1.53.0.0ubuntu2 amd64 Boost

aqiruse gravatar imageaqiruse ( 2013-11-05 19:41:04 -0600 )edit

Well they are definitely installed. How about your environment variables? Output of env

scpeters gravatar imagescpeters ( 2013-11-05 20:20:02 -0600 )edit

Below is the environment variables. I am not sure what to be looking for in them though.

aqiruse gravatar imageaqiruse ( 2013-11-05 21:04:50 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-11-05 19:23:19 -0600

Jose Luis Rivero gravatar image

By any chance, did you follow the from source installation guide?

edit flag offensive delete link more

Comments

Yes I did, the output of it at the bottom of the other answer I just posted.

aqiruse gravatar imageaqiruse ( 2013-11-05 20:00:28 -0600 )edit

Thanks for the information. All looks ok to me. Could you please try to remove the build/ directory completely, create it again and run cmake ..?

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2013-11-06 07:05:56 -0600 )edit

I deleted the entire directory after performing a custom build of simbody, and performing the install command nkoenig gave. When I did that, and redownloaded the code, cmake completed without errors. I am in the process of building it now.

aqiruse gravatar imageaqiruse ( 2013-11-06 11:41:22 -0600 )edit

I was able to compile the code, however I had some trouble running it after the install. The path would be /usr/local/lib for the libgazebo* librarys i thought but instead it is /usr/local/lib/x86_64-linux-gnu/ on my system. Once I figured that out using find -name "libgazebo*" and corrected the bashrc I am able to launch gazebo now. Next comes ROS hookup.

aqiruse gravatar imageaqiruse ( 2013-11-07 02:29:34 -0600 )edit

Perfect, good luck. Could you mark this thread as solved clicking on the check button?

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2013-11-07 08:35:54 -0600 )edit
0

answered 2013-11-06 11:22:34 -0600

nkoenig gravatar image

Your sudo apt-get install did not work. I don't believe libsimbody-dev has been released for saucy.

Try this command:

sudo apt-get install build-essential libtinyxml-dev libboost-all-dev cmake mercurial pkg-config libprotoc-dev libprotobuf-dev protobuf-compiler libqt4-dev libtar-dev libcurl4-openssl-dev libcegui-mk2-dev libopenal-dev libtbb-dev libswscale-dev libavformat-dev libavcodec-dev libogre-1.8-dev libgts-dev libltdl3-dev playerc++ libxml2-dev libfreeimage-dev freeglut3-dev

edit flag offensive delete link more

Comments

That command succeeded.

aqiruse gravatar imageaqiruse ( 2013-11-06 11:38:56 -0600 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-11-05 08:54:29 -0600

Seen: 2,152 times

Last updated: Nov 06 '13