Gazebo | Ignition | Community
Ask Your Question

GpuRaySensor.hh missing in 1.3?

asked 2012-12-12 10:10:22 -0600

yamokosk gravatar image

updated 2012-12-12 11:12:24 -0600

Looks like GpuRaySensor.hh went missing in Gazebo 1.3. I checked out the lastest source from the repo:

~/src/gazebo$ ls gazebo/sensors/Gpu*
gazebo/sensors/  gazebo/sensors/GpuRaySensor.hh

But in my installed (Ubuntu package), there is no more GpuRaySensor:

/usr/include/gazebo-1.3$ ls gazebo/sensors/Gpu*
ls: cannot access gazebo/sensors/Gpu*: No such file or directory

Pretty sure it was there in 1.2 and earlier as I had compiled worked on an extension to the base GpuRaySensor class.


Because I am impatient, I tried pulling in the relevant sources into my sensor that were missing from installed Gazebo 1.3 (GpuRaySensor.hh/.cc, GpuLaser.hh/.cc). But then ran into the following compile error:

In file included from .../plugins/src/
/usr/include/gazebo-1.3/gazebo/rendering/ogre_gazebo.h:22:18: fatal error: Ogre.h: No such file or directory

Looks like Ogre.h is in,


Not in,


Ultimately is this why GpuLaser didn't make it into 1.3?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2012-12-12 12:02:11 -0600

hsu gravatar image

updated 2012-12-13 13:15:30 -0600

Here's a gpu_sensors branch that should at least compile for you.

Opened an issue and a pull request.

It was not merged because we didn't get a chance to remove rendering::GpuLaser dependency on sensors::GpuRaySensor. Work in progress (see the pull request above).

edit flag offensive delete link more

answered 2012-12-12 11:27:53 -0600

nkoenig gravatar image

updated 2012-12-12 11:29:36 -0600

The gpu ray sensor was disabled because it had incorrect dependencies between libraries. We are working on a solution.

Here is the issue for this:

edit flag offensive delete link more

Question Tools


Asked: 2012-12-12 10:10:22 -0600

Seen: 264 times

Last updated: Dec 13 '12