Problems in Gazebo 2.0 unittests

asked 2013-11-14 17:15:12 -0500

mortonjt gravatar image

updated 2013-12-14 14:24:37 -0500

Right now, I'm trying to simulate a GPS sensor. I noticed that this has only been implemented in Gazebo 2.0, so I decided to build it from source.

The gazebo packages seemed to have compiled. However when I run the unit tests, a whole bunch of components fail, including the GPS sensor.

If I ignore the output from the unit tests, I get the following

Error [Plugin.hh:150] Failed to resolve RegisterPlugin: /home/jamie/Documents/Redblade/src/redblade_description/build/devel/lib/ undefined symbol: RegisterPlugin[ INFO] [1384470501.730233031, 0.001000000]: GazeboRosSkidSteerDrive Plugin (ns = /redblade/) missing <broadcastTF>, defaults to false.
[ INFO] [1384470501.730729529, 0.001000000]: Starting GazeboRosSkidSteerDrive Plugin (ns = /redblade/)!
[ INFO] [1384470501.774774168, 0.022000000]: waitForService: Service [/gazebo/set_physics_properties] is now available.
[ INFO] [1384470501.861474086, 0.069000000]: Physics dynamic reconfigure ready.

I'm really not sure what to make of this error. My best guess is it is linked with the failed unit test.

Is there a functioning version of this module in another release? I've had quite a bit of success with Gazebo so far and it would be a shame if this module becomes a show stopper

edit retag flag offensive close merge delete


Can you describe the test failures? The tests are mostly passing in our continuous integration server:

scpeters gravatar imagescpeters ( 2013-11-14 18:33:11 -0500 )edit

I just built your code using catkin\_make and was able to launch the simulation successfully. I sourced devel/setup.bash before running. Is the folder with in your LD\_LIBRARY_PATH?

scpeters gravatar imagescpeters ( 2013-11-14 18:42:56 -0500 )edit

A part from the unit test problem, it sounds to me like a bad setup on the software. If you are going to use gazebo from source, you will also need to recompile rosgazebopkgs from source. If you only need gazebo2.0 and rosgazebopkgs (no other ros packages build on top of it) you could use gazebo-current and rosgazebopkgs from the OSRF repository (versions > 2.4.1).

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2013-11-14 18:45:44 -0500 )edit

That is probably it. I have the LD\_LIBRARY\_PATH setup correctly, so the library is found. However, I didn't realize that I also needed to compile ros\_gazebo\_pkgs from source also. Thanks!

mortonjt gravatar imagemortonjt ( 2013-11-14 19:41:59 -0500 )edit

I didn't compile ros_gazebo_pkgs from source, but it worked for me.

scpeters gravatar imagescpeters ( 2013-11-14 19:48:16 -0500 )edit

Yeah. Building ros_gazebo_packages from source didn't help. What version of gazebo are you running on scpeters? Did you build it from source? Also, what version of gcc are you using? I had problems when I tried to build with gcc-4.6

mortonjt gravatar imagemortonjt ( 2013-11-15 10:26:33 -0500 )edit