libgazebo_sdf_interface no found while running Gazebo-1.9

asked 2013-11-29 07:18:26 -0500

ercarrion43 gravatar image

updated 2013-12-01 13:03:37 -0500

When I run gazebo-1.9.1 on the terminal (as a standalone and installed from a debian pkg) I always get the same error:

gazebo-1.9.1: error while loading shared libraries: cannot open shared object file: No such file or directory

As far as I know this library is no more used by gazebo. Previously I had installed gazebo-1.0.1, by source. Before trying with 1.9 I unistalled the 1.0.1 by deleting the gazebo contents in /usr/local, where it was installed. So it seems to me that somehow gazebo is still looking for the old libraries. Somebody has any idea of how to fix that? I have done exactly the same in my laptop (or that's what I believe...) and the 1.9 version works perfectly.

I have seen several questions related with this one:

eg. link text

but all of them where related with the integration with ROS, which is not the case. Thanks in advance!

EDIT: I found where the error came from. As I said previously I had installed gazebo-1.0.1 and when uninstalling it (manually) I forgot to delete the gzserver executables in local/bin, so gazebo1.9.1 was calling gzserver1.0.1 which tried to find its libraries which were already deleted.

edit retag flag offensive close merge delete


Perfect. Please mark the question as already answered clicking on the check signal.

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2013-12-02 17:00:03 -0500 )edit